Bug 1201978 - (CVE-2016-3709) VUL-0: CVE-2016-3709: libxml2,libxml2-python,rubygem-nokogiri: Cross-site scripting vulnerability in libxml
(CVE-2016-3709)
VUL-0: CVE-2016-3709: libxml2,libxml2-python,rubygem-nokogiri: Cross-site scr...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/338444/
CVSSv3.1:SUSE:CVE-2016-3709:6.8:(AV:L...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-07-29 08:40 UTC by Hu
Modified: 2022-08-30 07:29 UTC (History)
6 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hu 2022-07-29 08:40:02 UTC
CVE-2016-3709

Possible cross-site scripting vulnerability in libxml after commit 960f0e2.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-3709
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-3709
https://mail.gnome.org/archives/xml/2018-January/msg00010.html
Comment 1 Hu 2022-07-29 08:40:34 UTC
Fix: https://github.com/GNOME/libxml2/commit/c1ba6f54d32b707ca6d91cb3257ce9de82876b6f

Affected:
- SUSE:SLE-12-SP2:Update/libxml2            2.9.4
- SUSE:Carwos:1/libxml2                     2.9.7
- SUSE:SLE-15:Update/libxml2                2.9.7

Not affected (already contains fix):
- SUSE:SLE-11-SP1:Update/libxml2            2.7.6
- SUSE:SLE-11-SP1:Update/libxml2-python     2.7.6
- SUSE:SLE-15-SP4:Update/libxml2            2.9.14
- openSUSE:Factory/libxml2                  2.9.14
Comment 2 Moritz Duge 2022-08-02 10:50:40 UTC
If there will be a new libxml2 version, please coordinate with bug 1202053.
Comment 3 Thomas Leroy 2022-08-29 12:24:57 UTC
Reassigning.
David, could you please submit to SUSE:SLE-12-SP2:Update/libxml2 and SUSE:SLE-15:Update/libxml2 please? :)
Comment 4 Pedro Monreal Gonzalez 2022-08-29 16:48:47 UTC
(In reply to Thomas Leroy from comment #3)
> Reassigning.
> David, could you please submit to SUSE:SLE-12-SP2:Update/libxml2 and
> SUSE:SLE-15:Update/libxml2 please? :)

Hello, since David is on vacation I will take care of this.
Comment 6 Pedro Monreal Gonzalez 2022-08-29 20:59:17 UTC
For the nokogiri warning, note that both LibXML versions 2.9.{12,14} are ABI/API compatible. Since there is no libxml2 change for Leap 15.4, there is not much we can do from libxml2. A rebuild of the nokogiri package would fix the warning, please contact its maintainer.
Comment 7 Pedro Monreal Gonzalez 2022-08-29 21:00:19 UTC
(In reply to Thomas Leroy from comment #3)
> Reassigning.
> David, could you please submit to SUSE:SLE-12-SP2:Update/libxml2 and
> SUSE:SLE-15:Update/libxml2 please? :)

All submitted, assigning back to security-team.
Comment 8 Thomas Leroy 2022-08-30 07:29:49 UTC
(In reply to Pedro Monreal Gonzalez from comment #7)
> (In reply to Thomas Leroy from comment #3)
> > Reassigning.
> > David, could you please submit to SUSE:SLE-12-SP2:Update/libxml2 and
> > SUSE:SLE-15:Update/libxml2 please? :)
> 
> All submitted, assigning back to security-team.

Thank you very much Pedro!
FYI @Markus