Bug 978828 - (CVE-2016-4539) VUL-0: CVE-2016-4539: php5, php53: Malformed input causes segmentation fault in xml_parse_into_struct() function
(CVE-2016-4539)
VUL-0: CVE-2016-4539: php5, php53: Malformed input causes segmentation fault ...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/168656/
CVSSv2:SUSE:CVE-2016-4539:4.3:(AV:N/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-05-06 10:38 UTC by Alexander Bergmann
Modified: 2016-08-01 09:47 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bergmann 2016-05-06 10:38:57 UTC
rh#1332877 / CVE-2016-4539

It was found that crafted input to xml_parse_into_struct() function can cause segmentation fault.

Upstream bug:

https://bugs.php.net/bug.php?id=72099

Upstream patch:

https://git.php.net/?p=php-src.git;a=commit;h=1248079be837808da4c97364fb3b4c96c8015fbf

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1332877
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-4539
http://seclists.org/oss-sec/2016/q2/259
Comment 1 Swamp Workflow Management 2016-05-06 22:02:12 UTC
bugbot adjusting priority
Comment 2 Petr Gajdos 2016-05-10 10:50:46 UTC
I am not able to reproduce.
Comment 3 Petr Gajdos 2016-05-10 11:16:19 UTC
Packages submitted.
Comment 4 Bernhard Wiedemann 2016-05-10 12:00:59 UTC
This is an autogenerated message for OBS integration:
This bug (978828) was mentioned in
https://build.opensuse.org/request/show/394633 13.2 / php5
Comment 8 Bernhard Wiedemann 2016-05-18 14:00:42 UTC
This is an autogenerated message for OBS integration:
This bug (978828) was mentioned in
https://build.opensuse.org/request/show/396629 13.2 / php5
Comment 10 Swamp Workflow Management 2016-05-19 12:09:34 UTC
openSUSE-SU-2016:1357-1: An update that fixes 11 vulnerabilities is now available.

Category: security (moderate)
Bug References: 977991,977992,977994,978827,978828,978829,978830
CVE References: CVE-2016-4342,CVE-2016-4343,CVE-2016-4346,CVE-2016-4537,CVE-2016-4538,CVE-2016-4539,CVE-2016-4540,CVE-2016-4541,CVE-2016-4542,CVE-2016-4543,CVE-2016-4544
Sources used:
openSUSE 13.2 (src):    php5-5.6.1-61.1
Comment 14 Swamp Workflow Management 2016-06-06 19:08:18 UTC
SUSE-SU-2016:1504-1: An update that fixes 13 vulnerabilities is now available.

Category: security (moderate)
Bug References: 977991,977994,978827,978828,978829,978830,980366,980373,980375
CVE References: CVE-2015-4116,CVE-2015-8873,CVE-2015-8874,CVE-2016-4342,CVE-2016-4346,CVE-2016-4537,CVE-2016-4538,CVE-2016-4539,CVE-2016-4540,CVE-2016-4541,CVE-2016-4542,CVE-2016-4543,CVE-2016-4544
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP1 (src):    php5-5.5.14-59.2
SUSE Linux Enterprise Software Development Kit 12 (src):    php5-5.5.14-59.2
SUSE Linux Enterprise Module for Web Scripting 12 (src):    php5-5.5.14-59.2
Comment 15 Swamp Workflow Management 2016-06-08 10:08:47 UTC
openSUSE-SU-2016:1524-1: An update that fixes 13 vulnerabilities is now available.

Category: security (moderate)
Bug References: 977991,977994,978827,978828,978829,978830,980366,980373,980375
CVE References: CVE-2015-4116,CVE-2015-8873,CVE-2015-8874,CVE-2016-4342,CVE-2016-4346,CVE-2016-4537,CVE-2016-4538,CVE-2016-4539,CVE-2016-4540,CVE-2016-4541,CVE-2016-4542,CVE-2016-4543,CVE-2016-4544
Sources used:
openSUSE Leap 42.1 (src):    php5-5.5.14-50.1
Comment 16 Swamp Workflow Management 2016-06-14 18:10:53 UTC
SUSE-SU-2016:1581-1: An update that fixes 31 vulnerabilities is now available.

Category: security (important)
Bug References: 949961,968284,969821,971611,971612,971912,973351,973792,976996,976997,977003,977005,977991,977994,978827,978828,978829,978830,980366,980373,980375,981050,982010,982011,982012,982013,982162
CVE References: CVE-2014-9767,CVE-2015-4116,CVE-2015-7803,CVE-2015-8835,CVE-2015-8838,CVE-2015-8866,CVE-2015-8867,CVE-2015-8873,CVE-2015-8874,CVE-2015-8879,CVE-2016-2554,CVE-2016-3141,CVE-2016-3142,CVE-2016-3185,CVE-2016-4070,CVE-2016-4073,CVE-2016-4342,CVE-2016-4346,CVE-2016-4537,CVE-2016-4538,CVE-2016-4539,CVE-2016-4540,CVE-2016-4541,CVE-2016-4542,CVE-2016-4543,CVE-2016-4544,CVE-2016-5093,CVE-2016-5094,CVE-2016-5095,CVE-2016-5096,CVE-2016-5114
Sources used:
SUSE OpenStack Cloud 5 (src):    php53-5.3.17-71.1
SUSE Manager Proxy 2.1 (src):    php53-5.3.17-71.1
SUSE Manager 2.1 (src):    php53-5.3.17-71.1
SUSE Linux Enterprise Software Development Kit 11-SP4 (src):    php53-5.3.17-71.1
SUSE Linux Enterprise Server 11-SP4 (src):    php53-5.3.17-71.1
SUSE Linux Enterprise Server 11-SP3-LTSS (src):    php53-5.3.17-71.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    php53-5.3.17-71.1
SUSE Linux Enterprise Debuginfo 11-SP3 (src):    php53-5.3.17-71.1
Comment 17 Swamp Workflow Management 2016-06-21 11:19:40 UTC
SUSE-SU-2016:1638-1: An update that fixes 85 vulnerabilities is now available.

Category: security (important)
Bug References: 884986,884987,884989,884990,884991,884992,885961,886059,886060,893849,893853,902357,902360,902368,910659,914690,917150,918768,919080,921950,922451,922452,923945,924972,925109,928506,928511,931421,931769,931772,931776,933227,935074,935224,935226,935227,935229,935232,935234,935274,935275,938719,938721,942291,942296,945412,945428,949961,968284,969821,971611,971612,971912,973351,973792,976996,976997,977003,977005,977991,977994,978827,978828,978829,978830,980366,980373,980375,981050,982010,982011,982012,982013,982162
CVE References: CVE-2004-1019,CVE-2006-7243,CVE-2014-0207,CVE-2014-3478,CVE-2014-3479,CVE-2014-3480,CVE-2014-3487,CVE-2014-3515,CVE-2014-3597,CVE-2014-3668,CVE-2014-3669,CVE-2014-3670,CVE-2014-4049,CVE-2014-4670,CVE-2014-4698,CVE-2014-4721,CVE-2014-5459,CVE-2014-8142,CVE-2014-9652,CVE-2014-9705,CVE-2014-9709,CVE-2014-9767,CVE-2015-0231,CVE-2015-0232,CVE-2015-0273,CVE-2015-1352,CVE-2015-2301,CVE-2015-2305,CVE-2015-2783,CVE-2015-2787,CVE-2015-3152,CVE-2015-3329,CVE-2015-3411,CVE-2015-3412,CVE-2015-4021,CVE-2015-4022,CVE-2015-4024,CVE-2015-4026,CVE-2015-4116,CVE-2015-4148,CVE-2015-4598,CVE-2015-4599,CVE-2015-4600,CVE-2015-4601,CVE-2015-4602,CVE-2015-4603,CVE-2015-4643,CVE-2015-4644,CVE-2015-5161,CVE-2015-5589,CVE-2015-5590,CVE-2015-6831,CVE-2015-6833,CVE-2015-6836,CVE-2015-6837,CVE-2015-6838,CVE-2015-7803,CVE-2015-8835,CVE-2015-8838,CVE-2015-8866,CVE-2015-8867,CVE-2015-8873,CVE-2015-8874,CVE-2015-8879,CVE-2016-2554,CVE-2016-3141,CVE-2016-3142,CVE-2016-3185,CVE-2016-4070,CVE-2016-4073,CVE-2016-4342,CVE-2016-4346,CVE-2016-4537,CVE-2016-4538,CVE-2016-4539,CVE-2016-4540,CVE-2016-4541,CVE-2016-4542,CVE-2016-4543,CVE-2016-4544,CVE-2016-5093,CVE-2016-5094,CVE-2016-5095,CVE-2016-5096,CVE-2016-5114
Sources used:
SUSE Linux Enterprise Server 11-SP2-LTSS (src):    php53-5.3.17-47.1
Comment 18 Marcus Meissner 2016-08-01 09:47:32 UTC
all released