Bug 1045460 - (CVE-2017-2538) VUL-0: CVE-2017-2538: webkitgtk: Processing maliciously crafted web content may lead to arbitrary code execution.
(CVE-2017-2538)
VUL-0: CVE-2017-2538: webkitgtk: Processing maliciously crafted web content m...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: E-mail List
Security Team bot
https://smash.suse.de/issue/185529/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-22 07:18 UTC by Alexander Bergmann
Modified: 2017-11-10 17:22 UTC (History)
5 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bergmann 2017-06-22 07:18:39 UTC
WebKitGTK+ Security Advisory WSA-2017-0005

https://webkitgtk.org/security/WSA-2017-0005.html

Date Reported: June 21, 2017
Advisory ID: WSA-2017-0005

CVE identifier: CVE-2017-2538

Versions affected: WebKitGTK+ before 2.16.4.

Credit to Richard Zhu (fluorescence) working with Trend Micro’s Zero Day Initiative.

Impact: Processing maliciously crafted web content may lead to arbitrary code execution.

Description: Multiple memory corruption issues were addressed with improved memory handling.
Comment 1 Bjørn Lie 2017-06-22 08:01:12 UTC
https://build.opensuse.org/request/show/505536 - on it's way to devel project -> then to TW. (Built ok in GNOME:Next)

So fixed for Tumbleweed in the near future.

Adding some SLE people for SLE/Leap
Comment 2 Bjørn Lie 2017-06-22 20:10:30 UTC
https://build.opensuse.org/request/show/505721 fix en route to TW

Leave it up to TW distro maintainer if this should land in TW:Update
Comment 3 Federico Mena Quintero 2017-06-23 04:06:48 UTC
I'm using this 2.16.4 update for SLE-12-SP3.  Thanks for updating it so quickly :)
Comment 4 Swamp Workflow Management 2017-11-06 14:08:57 UTC
SUSE-SU-2017:2933-1: An update that fixes 40 vulnerabilities is now available.

Category: security (important)
Bug References: 1020950,1024749,1045460,1050469
CVE References: CVE-2016-7586,CVE-2016-7589,CVE-2016-7592,CVE-2016-7599,CVE-2016-7623,CVE-2016-7632,CVE-2016-7635,CVE-2016-7639,CVE-2016-7641,CVE-2016-7645,CVE-2016-7652,CVE-2016-7654,CVE-2016-7656,CVE-2017-2350,CVE-2017-2354,CVE-2017-2355,CVE-2017-2356,CVE-2017-2362,CVE-2017-2363,CVE-2017-2364,CVE-2017-2365,CVE-2017-2366,CVE-2017-2369,CVE-2017-2371,CVE-2017-2373,CVE-2017-2496,CVE-2017-2510,CVE-2017-2538,CVE-2017-2539,CVE-2017-7018,CVE-2017-7030,CVE-2017-7034,CVE-2017-7037,CVE-2017-7039,CVE-2017-7046,CVE-2017-7048,CVE-2017-7055,CVE-2017-7056,CVE-2017-7061,CVE-2017-7064
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP3 (src):    webkit2gtk3-2.18.0-2.9.1
SUSE Linux Enterprise Workstation Extension 12-SP2 (src):    webkit2gtk3-2.18.0-2.9.1
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    webkit2gtk3-2.18.0-2.9.1
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    webkit2gtk3-2.18.0-2.9.1
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    webkit2gtk3-2.18.0-2.9.1
SUSE Linux Enterprise Server 12-SP3 (src):    webkit2gtk3-2.18.0-2.9.1
SUSE Linux Enterprise Server 12-SP2 (src):    webkit2gtk3-2.18.0-2.9.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    webkit2gtk3-2.18.0-2.9.1
SUSE Linux Enterprise Desktop 12-SP2 (src):    webkit2gtk3-2.18.0-2.9.1
Comment 5 Andreas Stieger 2017-11-10 13:25:55 UTC
done closing
Comment 6 Swamp Workflow Management 2017-11-10 17:22:55 UTC
openSUSE-SU-2017:2991-1: An update that fixes 40 vulnerabilities is now available.

Category: security (important)
Bug References: 1020950,1024749,1045460,1050469
CVE References: CVE-2016-7586,CVE-2016-7589,CVE-2016-7592,CVE-2016-7599,CVE-2016-7623,CVE-2016-7632,CVE-2016-7635,CVE-2016-7639,CVE-2016-7641,CVE-2016-7645,CVE-2016-7652,CVE-2016-7654,CVE-2016-7656,CVE-2017-2350,CVE-2017-2354,CVE-2017-2355,CVE-2017-2356,CVE-2017-2362,CVE-2017-2363,CVE-2017-2364,CVE-2017-2365,CVE-2017-2366,CVE-2017-2369,CVE-2017-2371,CVE-2017-2373,CVE-2017-2496,CVE-2017-2510,CVE-2017-2538,CVE-2017-2539,CVE-2017-7018,CVE-2017-7030,CVE-2017-7034,CVE-2017-7037,CVE-2017-7039,CVE-2017-7046,CVE-2017-7048,CVE-2017-7055,CVE-2017-7056,CVE-2017-7061,CVE-2017-7064
Sources used:
openSUSE Leap 42.3 (src):    webkit2gtk3-2.18.0-5.1
openSUSE Leap 42.2 (src):    webkit2gtk3-2.18.0-2.3.1