Bug 1023848 - (CVE-2017-5834) VUL-1: CVE-2017-5834: libplist: Heap-buffer overflow in parse_dict_node
(CVE-2017-5834)
VUL-1: CVE-2017-5834: libplist: Heap-buffer overflow in parse_dict_node
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Normal
: ---
Assigned To: Antonio Larrosa
Security Team bot
https://smash.suse.de/issue/179870/
CVSSv2:SUSE:CVE-2017-5834:4.3:(AV:N/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-06 16:47 UTC by Matthias Gerstner
Modified: 2017-05-28 01:09 UTC (History)
4 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 2 Matthias Gerstner 2017-02-06 16:52:41 UTC
QA reproducer:

Using the PoC file from the upstream bug
https://github.com/libimobiledevice/libplist/files/712874/poc17.txt I was able
to reproduce the issue in all codestreams like this:

  plistutil -i poc17.txt

This causes a segmentation fault.
Comment 4 Swamp Workflow Management 2017-02-06 23:01:21 UTC
bugbot adjusting priority
Comment 5 Swamp Workflow Management 2017-02-20 23:08:39 UTC
openSUSE-SU-2017:0528-1: An update that fixes four vulnerabilities is now available.

Category: security (moderate)
Bug References: 1019531,1023807,1023822,1023848
CVE References: CVE-2017-5209,CVE-2017-5834,CVE-2017-5835,CVE-2017-5836
Sources used:
openSUSE Leap 42.1 (src):    libplist-1.12-7.1
Comment 6 Swamp Workflow Management 2017-05-22 13:12:40 UTC
SUSE-SU-2017:1368-1: An update that fixes 7 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1019531,1021610,1023807,1023822,1023848,1029631,1035312
CVE References: CVE-2017-5209,CVE-2017-5545,CVE-2017-5834,CVE-2017-5835,CVE-2017-5836,CVE-2017-6440,CVE-2017-7982
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP1 (src):    libplist-1.8-10.9.1
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    libplist-1.8-10.9.1
SUSE Linux Enterprise Software Development Kit 12-SP1 (src):    libplist-1.8-10.9.1
SUSE Linux Enterprise Server 12-SP1 (src):    libplist-1.8-10.9.1
SUSE Linux Enterprise Desktop 12-SP1 (src):    libplist-1.8-10.9.1
Comment 7 Swamp Workflow Management 2017-05-23 19:09:53 UTC
SUSE-SU-2017:1379-1: An update that fixes 7 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1019531,1021610,1023807,1023822,1023848,1029631,1035312
CVE References: CVE-2017-5209,CVE-2017-5545,CVE-2017-5834,CVE-2017-5835,CVE-2017-5836,CVE-2017-6440,CVE-2017-7982
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP2 (src):    libplist-1.12-19.1
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    libplist-1.12-19.1
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    libplist-1.12-19.1
SUSE Linux Enterprise Server 12-SP2 (src):    libplist-1.12-19.1
SUSE Linux Enterprise Desktop 12-SP2 (src):    libplist-1.12-19.1
Comment 8 Andreas Stieger 2017-05-27 19:52:30 UTC
done
Comment 9 Swamp Workflow Management 2017-05-28 01:09:20 UTC
openSUSE-SU-2017:1426-1: An update that fixes 7 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1019531,1021610,1023807,1023822,1023848,1029631,1035312
CVE References: CVE-2017-5209,CVE-2017-5545,CVE-2017-5834,CVE-2017-5835,CVE-2017-5836,CVE-2017-6440,CVE-2017-7982
Sources used:
openSUSE Leap 42.2 (src):    libplist-1.12-7.3.1