Bug 1024030 - (CVE-2017-5841) VUL-1: CVE-2017-5841: gstreamer-plugins-good: Heap out-of-bounds read in gst_avi_demux_parse_ncdt
(CVE-2017-5841)
VUL-1: CVE-2017-5841: gstreamer-plugins-good: Heap out-of-bounds read in gst_...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Normal
: ---
Assigned To: Antonio Larrosa
Security Team bot
https://smash.suse.de/issue/179849/
CVSSv2:SUSE:CVE-2017-5841:4.3:(AV:N/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-02-07 12:50 UTC by Matthias Gerstner
Modified: 2017-07-11 15:21 UTC (History)
7 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Matthias Gerstner 2017-02-07 12:54:19 UTC
Only

SUSE:SLE-12-SP2:Update/gstreamer-plugins-good/gst-plugins-good-1.8.3/gst/avi/gstavidemux.c:3898,3916,3933

is affected. SLE-12:Update contains the demuxer but no support for the ncdt
tag parsing. valgrind shows no errors on SLE-12:Update.

QA reproducer:

Using the PoC file from https://bugzilla.gnome.org/attachment.cgi?id=343859
I've been able to reproduce the issue on SLES-12-SP2 the following way:

  valgrind gst-discoverer-1.0 DSC_0131.AVI

valgrind will print errors about invalid read accesses.
Comment 2 Swamp Workflow Management 2017-02-07 23:01:26 UTC
bugbot adjusting priority
Comment 5 Antonio Larrosa 2017-02-16 16:21:32 UTC
I made a few SRs to fix this:
https://build.suse.de/request/show/128202 for SLE12-SP2 (which will go automatically to Leap 42.2 once the fix is released)
SLE12 is not affected.
https://build.opensuse.org/request/show/458517 for Leap 42.1
Factory is not affected.
Comment 6 Swamp Workflow Management 2017-04-13 13:14:16 UTC
SUSE-SU-2017:1010-1: An update that fixes 5 vulnerabilities is now available.

Category: security (low)
Bug References: 1024014,1024017,1024030,1024034,1024062
CVE References: CVE-2016-10198,CVE-2016-10199,CVE-2017-5840,CVE-2017-5841,CVE-2017-5845
Sources used:
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    gstreamer-plugins-good-1.8.3-12.12
SUSE Linux Enterprise Server 12-SP2 (src):    gstreamer-plugins-good-1.8.3-12.12
SUSE Linux Enterprise Desktop 12-SP2 (src):    gstreamer-plugins-good-1.8.3-12.12
Comment 7 Swamp Workflow Management 2017-04-19 19:12:39 UTC
openSUSE-SU-2017:1066-1: An update that fixes 5 vulnerabilities is now available.

Category: security (low)
Bug References: 1024014,1024017,1024030,1024034,1024062
CVE References: CVE-2016-10198,CVE-2016-10199,CVE-2017-5840,CVE-2017-5841,CVE-2017-5845
Sources used:
openSUSE Leap 42.2 (src):    gstreamer-plugins-good-1.8.3-5.3.1
Comment 8 Swamp Workflow Management 2017-04-20 13:13:26 UTC
openSUSE-SU-2017:1076-1: An update that fixes 5 vulnerabilities is now available.

Category: security (low)
Bug References: 1024014,1024017,1024030,1024034,1024062
CVE References: CVE-2016-10198,CVE-2016-10199,CVE-2017-5840,CVE-2017-5841,CVE-2017-5845
Sources used:
openSUSE Leap 42.1 (src):    gstreamer-plugins-good-1.4.5-8.1
Comment 9 Johannes Segitz 2017-07-11 15:21:43 UTC
fixed