Bug 1030263 - (CVE-2017-7207) VUL-1: CVE-2017-7207: ghostscript, ghostscript-library: The mem_get_bits_rectangle function allows remote attackers to cause a denial of service
(CVE-2017-7207)
VUL-1: CVE-2017-7207: ghostscript, ghostscript-library: The mem_get_bits_rect...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/182077/
CVSSv2:SUSE:CVE-2017-7207:1.5:(AV:L/A...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-21 09:50 UTC by Johannes Segitz
Modified: 2020-06-11 16:26 UTC (History)
5 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
QA reproducer (221 bytes, text/plain)
2017-04-28 14:01 UTC, Vítězslav Čížek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Segitz 2017-03-21 09:50:29 UTC
CVE-2017-7207

The mem_get_bits_rectangle function in Artifex Software, Inc. Ghostscript 9.20
allows remote attackers to cause a denial of service (NULL pointer dereference)
via a crafted PostScript document.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-7207
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7207
https://bugs.ghostscript.com/show_bug.cgi?id=697676
http://www.ghostscript.com/cgi-bin/findgit.cgi?309eca4e0a31ea70dcc844812691439312dad091
Comment 1 Vítězslav Čížek 2017-04-28 08:38:50 UTC
Fix is available at http://git.ghostscript.com/?p=ghostpdl.git;h=309eca4e0a31ea70dcc844812691439312dad091
Comment 3 Vítězslav Čížek 2017-04-28 14:01:49 UTC
Created attachment 723162 [details]
QA reproducer

Command: gs -dNOPAUSE -sDEVICE=bit -sOUTPUTFILE=/dev/null -dSAFER gs_null_ptr_mem_get_bits_rectangle -c quit
Comment 4 Swamp Workflow Management 2017-04-28 22:09:17 UTC
SUSE-SU-2017:1138-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1018128,1030263,1032114,1032120,1036453
CVE References: CVE-2016-10220,CVE-2016-9601,CVE-2017-5951,CVE-2017-7207,CVE-2017-8291
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    ghostscript-9.15-20.1
SUSE Linux Enterprise Software Development Kit 12-SP1 (src):    ghostscript-9.15-20.1
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    ghostscript-9.15-20.1
SUSE Linux Enterprise Server 12-SP2 (src):    ghostscript-9.15-20.1
SUSE Linux Enterprise Server 12-SP1 (src):    ghostscript-9.15-20.1
SUSE Linux Enterprise Desktop 12-SP2 (src):    ghostscript-9.15-20.1
SUSE Linux Enterprise Desktop 12-SP1 (src):    ghostscript-9.15-20.1
Comment 5 Swamp Workflow Management 2017-05-08 16:16:01 UTC
openSUSE-SU-2017:1203-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1018128,1030263,1032114,1032120,1036453
CVE References: CVE-2016-10220,CVE-2016-9601,CVE-2017-5951,CVE-2017-7207,CVE-2017-8291
Sources used:
openSUSE Leap 42.2 (src):    ghostscript-9.15-11.3.1, ghostscript-mini-9.15-11.3.1
openSUSE Leap 42.1 (src):    ghostscript-9.15-17.1, ghostscript-mini-9.15-17.1
Comment 6 Swamp Workflow Management 2017-05-24 19:13:48 UTC
SUSE-SU-2017:1404-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1018128,1030263,1032114,1032120,1036453
CVE References: CVE-2016-10220,CVE-2016-9601,CVE-2017-5951,CVE-2017-7207,CVE-2017-8291
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP2 (src):    ghostscript-9.15-22.1
SUSE Linux Enterprise Software Development Kit 12-SP1 (src):    ghostscript-9.15-22.1
SUSE Linux Enterprise Server for SAP 12 (src):    ghostscript-9.15-22.1
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (src):    ghostscript-9.15-22.1
SUSE Linux Enterprise Server 12-SP2 (src):    ghostscript-9.15-22.1
SUSE Linux Enterprise Server 12-SP1 (src):    ghostscript-9.15-22.1
SUSE Linux Enterprise Server 12-LTSS (src):    ghostscript-9.15-22.1
SUSE Linux Enterprise Desktop 12-SP2 (src):    ghostscript-9.15-22.1
SUSE Linux Enterprise Desktop 12-SP1 (src):    ghostscript-9.15-22.1
Comment 7 Bernhard Wiedemann 2017-06-06 10:00:51 UTC
This is an autogenerated message for OBS integration:
This bug (1030263) was mentioned in
https://build.opensuse.org/request/show/501328 Factory / ghostscript
Comment 8 Daniel Molkentin 2017-06-08 11:23:30 UTC
Reassigning to security team for further handling.
Comment 9 Marcus Meissner 2017-06-15 19:38:58 UTC
released
Comment 11 Swamp Workflow Management 2018-05-03 13:07:34 UTC
SUSE-SU-2018:1140-1: An update that solves 10 vulnerabilities and has one errata is now available.

Category: security (moderate)
Bug References: 1018128,1030263,1032138,1032230,1040643,1050879,1050887,1050888,1050889,1050891,1051184
CVE References: CVE-2016-10219,CVE-2016-9601,CVE-2017-11714,CVE-2017-7207,CVE-2017-9216,CVE-2017-9612,CVE-2017-9726,CVE-2017-9727,CVE-2017-9739,CVE-2017-9835
Sources used:
SUSE Linux Enterprise Software Development Kit 11-SP4 (src):    ghostscript-library-8.62-32.47.7.1
SUSE Linux Enterprise Server 11-SP4 (src):    ghostscript-library-8.62-32.47.7.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    ghostscript-library-8.62-32.47.7.1
Comment 13 Marcus Meissner 2020-01-27 15:40:34 UTC
released