Bug 1042808 - (CVE-2017-9430) VUL-0: CVE-2017-9430: dnstracer: Stack-based buffer overflow could cause denial of service
(CVE-2017-9430)
VUL-0: CVE-2017-9430: dnstracer: Stack-based buffer overflow could cause deni...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other openSUSE 42.2
: P3 - Medium : Normal
: ---
Assigned To: Martin Hauke
Security Team bot
https://smash.suse.de/issue/186248/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 06:17 UTC by Victor Pereira
Modified: 2018-10-30 14:02 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Pereira 2017-06-06 06:17:50 UTC
CVE-2017-9430

Stack-based buffer overflow in dnstracer through 1.9 allows attackers to cause a
denial of service (application crash) or possibly have unspecified other impact
via a command line with a long name argument that is mishandled in a strcpy call
for argv[0]. An example threat model is a web application that launches
dnstracer with an untrusted name string.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2017-9430
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9430
https://cxsecurity.com/issue/WLB-2017060030
Comment 1 Johannes Segitz 2017-08-07 10:34:47 UTC
we have no maintainer for this, would you be willing to submit for this?