Bug 1123832 - (CVE-2018-20750) VUL-0: CVE-2018-20750: LibVNCServer: heap out-of-bounds write vulnerability in libvncserver/rfbserver.c
(CVE-2018-20750)
VUL-0: CVE-2018-20750: LibVNCServer: heap out-of-bounds write vulnerability i...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Critical
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/223985/
CVSSv3:SUSE:CVE-2018-20750:9.8:(AV:N...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-01-31 10:55 UTC by Alexandros Toptsoglou
Modified: 2021-09-17 10:40 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Alexandros Toptsoglou 2019-01-31 10:56:21 UTC
The patch for CVE-2018-15127 did not fix completely that issue and thus this CVE was created. A fix is already available at [1] 

All our codestreams contain this patch and are also affected. 

This bug is different than [2] 

[1] https://github.com/LibVNC/libvncserver/commit/09e8fc02f59f16e2583b34fe1a270c238bd9ffec

[2] https://bugzilla.suse.com/show_bug.cgi?id=1123828
Comment 2 Petr Gajdos 2019-02-05 13:03:14 UTC
0.9.12 submitted into develproject.
Comment 3 Petr Gajdos 2019-02-05 14:17:49 UTC
Packages submitted into 15,12,11/LibVNCServer.
Comment 4 Petr Gajdos 2019-02-05 14:18:50 UTC
I believe all fixed.
Comment 6 Swamp Workflow Management 2019-02-07 17:13:10 UTC
SUSE-SU-2019:0283-1: An update that fixes three vulnerabilities is now available.

Category: security (critical)
Bug References: 1123823,1123828,1123832
CVE References: CVE-2018-20748,CVE-2018-20749,CVE-2018-20750
Sources used:
SUSE Linux Enterprise Workstation Extension 15 (src):    LibVNCServer-0.9.10-4.6.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15 (src):    LibVNCServer-0.9.10-4.6.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    LibVNCServer-0.9.10-4.6.1
Comment 7 Swamp Workflow Management 2019-02-09 14:08:56 UTC
SUSE-SU-2019:0313-1: An update that fixes three vulnerabilities is now available.

Category: security (critical)
Bug References: 1123823,1123828,1123832
CVE References: CVE-2018-20748,CVE-2018-20749,CVE-2018-20750
Sources used:
SUSE OpenStack Cloud 7 (src):    LibVNCServer-0.9.9-17.11.1
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    LibVNCServer-0.9.9-17.11.1
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    LibVNCServer-0.9.9-17.11.1
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    LibVNCServer-0.9.9-17.11.1
SUSE Linux Enterprise Server 12-SP4 (src):    LibVNCServer-0.9.9-17.11.1
SUSE Linux Enterprise Server 12-SP3 (src):    LibVNCServer-0.9.9-17.11.1
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    LibVNCServer-0.9.9-17.11.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    LibVNCServer-0.9.9-17.11.1
SUSE Linux Enterprise Server 12-SP1-LTSS (src):    LibVNCServer-0.9.9-17.11.1
SUSE Linux Enterprise Server 12-LTSS (src):    LibVNCServer-0.9.9-17.11.1
SUSE Enterprise Storage 4 (src):    LibVNCServer-0.9.9-17.11.1
Comment 8 Swamp Workflow Management 2019-02-12 17:11:32 UTC
SUSE-SU-2019:13952-1: An update that fixes three vulnerabilities is now available.

Category: security (critical)
Bug References: 1123823,1123828,1123832
CVE References: CVE-2018-20748,CVE-2018-20749,CVE-2018-20750
Sources used:
SUSE Linux Enterprise Software Development Kit 11-SP4 (src):    LibVNCServer-0.9.1-160.9.1
SUSE Linux Enterprise Server 11-SP4 (src):    LibVNCServer-0.9.1-160.9.1
SUSE Linux Enterprise Point of Sale 11-SP3 (src):    LibVNCServer-0.9.1-160.9.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    LibVNCServer-0.9.1-160.9.1
SUSE Linux Enterprise Debuginfo 11-SP3 (src):    LibVNCServer-0.9.1-160.9.1
Comment 9 Swamp Workflow Management 2019-02-18 14:11:54 UTC
openSUSE-SU-2019:0196-1: An update that fixes three vulnerabilities is now available.

Category: security (critical)
Bug References: 1123823,1123828,1123832
CVE References: CVE-2018-20748,CVE-2018-20749,CVE-2018-20750
Sources used:
openSUSE Leap 15.0 (src):    LibVNCServer-0.9.10-lp150.3.6.1
Comment 10 Swamp Workflow Management 2019-02-18 20:10:15 UTC
openSUSE-SU-2019:0200-1: An update that fixes three vulnerabilities is now available.

Category: security (critical)
Bug References: 1123823,1123828,1123832
CVE References: CVE-2018-20748,CVE-2018-20749,CVE-2018-20750
Sources used:
openSUSE Leap 42.3 (src):    LibVNCServer-0.9.9-16.9.1
Comment 11 Marcus Meissner 2019-02-27 18:15:29 UTC
done
Comment 12 Swamp Workflow Management 2019-04-29 10:12:21 UTC
SUSE-SU-2019:0313-2: An update that fixes three vulnerabilities is now available.

Category: security (critical)
Bug References: 1123823,1123828,1123832
CVE References: CVE-2018-20748,CVE-2018-20749,CVE-2018-20750
Sources used:
SUSE Linux Enterprise Server for SAP 12-SP1 (src):    LibVNCServer-0.9.9-17.11.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 13 OBSbugzilla Bot 2021-09-17 10:40:12 UTC
This is an autogenerated message for OBS integration:
This bug (1123832) was mentioned in
https://build.opensuse.org/request/show/919689 Factory / LibVNCServer