Bug 1186247 - (CVE-2018-25011) VUL-0: CVE-2018-25011: libwebp: heap-based buffer overflow in PutLE16()
(CVE-2018-25011)
VUL-0: CVE-2018-25011: libwebp: heap-based buffer overflow in PutLE16()
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/283431/
CVSSv3.1:SUSE:CVE-2018-25011:9.8:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-05-19 13:07 UTC by Gianluca Gabrielli
Modified: 2021-08-05 13:23 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gianluca Gabrielli 2021-05-19 13:07:23 UTC
CVE-2018-25011

A heap-based buffer overflow was found in libwebp in versions before 1.0.1 in PutLE16().

Reference:
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9119

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1956919
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-25011
Comment 1 Gianluca Gabrielli 2021-05-19 13:08:24 UTC
Upstream patch here [0].

Affected packages:

- SUSE:SLE-12-SP1:Update/libwebp 0.4.3
- SUSE:SLE-15:Update/libwebp     0.5.0

[0] https://chromium.googlesource.com/webm/libwebp/+log/be738c6d396fa5a272c1b209be4379a7532debfe..29fb8562c60b5a919a75d904ff7366af423f8ab9?pretty=fuller&n=10000
Comment 6 Swamp Workflow Management 2021-06-02 16:19:54 UTC
SUSE-SU-2021:1830-1: An update that fixes 9 vulnerabilities is now available.

Category: security (critical)
Bug References: 1185652,1185654,1185673,1185674,1185685,1185686,1185690,1185691,1186247
CVE References: CVE-2018-25009,CVE-2018-25010,CVE-2018-25011,CVE-2018-25012,CVE-2018-25013,CVE-2020-36329,CVE-2020-36330,CVE-2020-36331,CVE-2020-36332
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    libwebp-0.4.3-4.7.1
SUSE OpenStack Cloud Crowbar 8 (src):    libwebp-0.4.3-4.7.1
SUSE OpenStack Cloud 9 (src):    libwebp-0.4.3-4.7.1
SUSE OpenStack Cloud 8 (src):    libwebp-0.4.3-4.7.1
SUSE OpenStack Cloud 7 (src):    libwebp-0.4.3-4.7.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    libwebp-0.4.3-4.7.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    libwebp-0.4.3-4.7.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    libwebp-0.4.3-4.7.1
SUSE Linux Enterprise Server 12-SP5 (src):    libwebp-0.4.3-4.7.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    libwebp-0.4.3-4.7.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    libwebp-0.4.3-4.7.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    libwebp-0.4.3-4.7.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    libwebp-0.4.3-4.7.1
HPE Helion Openstack 8 (src):    libwebp-0.4.3-4.7.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2021-06-04 10:35:36 UTC
SUSE-SU-2021:1860-1: An update that fixes 10 vulnerabilities is now available.

Category: security (critical)
Bug References: 1185652,1185654,1185673,1185674,1185685,1185686,1185688,1185690,1185691,1186247
CVE References: CVE-2018-25009,CVE-2018-25010,CVE-2018-25011,CVE-2018-25012,CVE-2018-25013,CVE-2020-36328,CVE-2020-36329,CVE-2020-36330,CVE-2020-36331,CVE-2020-36332
JIRA References: 
Sources used:
SUSE Manager Server 4.0 (src):    libwebp-0.5.0-3.5.1
SUSE Manager Retail Branch Server 4.0 (src):    libwebp-0.5.0-3.5.1
SUSE Manager Proxy 4.0 (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise Workstation Extension 15-SP3 (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise Workstation Extension 15-SP2 (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise Server for SAP 15 (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise Server 15-LTSS (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP2 (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    libwebp-0.5.0-3.5.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    libwebp-0.5.0-3.5.1
SUSE Enterprise Storage 6 (src):    libwebp-0.5.0-3.5.1
SUSE CaaS Platform 4.0 (src):    libwebp-0.5.0-3.5.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2021-07-10 22:32:11 UTC
openSUSE-SU-2021:1860-1: An update that fixes 10 vulnerabilities is now available.

Category: security (critical)
Bug References: 1185652,1185654,1185673,1185674,1185685,1185686,1185688,1185690,1185691,1186247
CVE References: CVE-2018-25009,CVE-2018-25010,CVE-2018-25011,CVE-2018-25012,CVE-2018-25013,CVE-2020-36328,CVE-2020-36329,CVE-2020-36330,CVE-2020-36331,CVE-2020-36332
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    libwebp-0.5.0-3.5.1
Comment 9 Marcus Meissner 2021-08-05 13:23:53 UTC
15-sp2 was not affected