Bug 1090026 - (CVE-2018-2796) VUL-0: CVE-2018-2796: java-1_8_0-openjdk, java-1_7_0-openjdk: Unspecified vulnerability in subcomponent Concurrency
(CVE-2018-2796)
VUL-0: CVE-2018-2796: java-1_8_0-openjdk, java-1_7_0-openjdk: Unspecified vul...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Fridrich Strba
Security Team bot
CVSSv3:RedHat:CVE-2018-2796:5.3:(AV:N...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-04-18 10:19 UTC by Johannes Segitz
Modified: 2019-06-08 16:24 UTC (History)
0 users

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Segitz 2018-04-18 10:19:38 UTC
Oracle April 2018 Patch Day.
   
http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html#AppendixJAVA
http://www.oracle.com/technetwork/security-advisory/cpuapr2018verbose-3678108.html#JAVA

Vulnerability in the Java SE, Java SE Embedded, JRockit component of Oracle Java SE (subcomponent: Concurrency). Supported versions that are affected are Java SE: 7u171, 8u162 and 10; Java SE Embedded: 8u161; JRockit: R28.3.17. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded, JRockit. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded, JRockit.

Applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service.

CVSS v3.0 Base Score 5.3 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L).
Comment 1 Swamp Workflow Management 2018-06-14 13:11:55 UTC
SUSE-SU-2018:1690-1: An update that solves 10 vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1087066,1090023,1090024,1090025,1090026,1090027,1090028,1090029,1090030,1090032,1090033
CVE References: CVE-2018-2790,CVE-2018-2794,CVE-2018-2795,CVE-2018-2796,CVE-2018-2797,CVE-2018-2798,CVE-2018-2799,CVE-2018-2800,CVE-2018-2814,CVE-2018-2815
Sources used:
SUSE OpenStack Cloud 7 (src):    java-1_8_0-openjdk-1.8.0.171-27.19.1
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    java-1_8_0-openjdk-1.8.0.171-27.19.1
SUSE Linux Enterprise Server for SAP 12-SP1 (src):    java-1_8_0-openjdk-1.8.0.171-27.19.1
SUSE Linux Enterprise Server 12-SP3 (src):    java-1_8_0-openjdk-1.8.0.171-27.19.1
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    java-1_8_0-openjdk-1.8.0.171-27.19.1
SUSE Linux Enterprise Server 12-SP1-LTSS (src):    java-1_8_0-openjdk-1.8.0.171-27.19.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    java-1_8_0-openjdk-1.8.0.171-27.19.1
SUSE Enterprise Storage 4 (src):    java-1_8_0-openjdk-1.8.0.171-27.19.1
Comment 2 Swamp Workflow Management 2018-06-14 13:22:38 UTC
SUSE-SU-2018:1692-1: An update that fixes 10 vulnerabilities is now available.

Category: security (important)
Bug References: 1090023,1090024,1090025,1090026,1090027,1090028,1090029,1090030,1090032,1090033
CVE References: CVE-2018-2790,CVE-2018-2794,CVE-2018-2795,CVE-2018-2796,CVE-2018-2797,CVE-2018-2798,CVE-2018-2799,CVE-2018-2800,CVE-2018-2814,CVE-2018-2815
Sources used:
SUSE OpenStack Cloud 7 (src):    java-1_7_0-openjdk-1.7.0.181-43.15.2
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    java-1_7_0-openjdk-1.7.0.181-43.15.2
SUSE Linux Enterprise Server for SAP 12-SP1 (src):    java-1_7_0-openjdk-1.7.0.181-43.15.2
SUSE Linux Enterprise Server 12-SP3 (src):    java-1_7_0-openjdk-1.7.0.181-43.15.2
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    java-1_7_0-openjdk-1.7.0.181-43.15.2
SUSE Linux Enterprise Server 12-SP1-LTSS (src):    java-1_7_0-openjdk-1.7.0.181-43.15.2
SUSE Linux Enterprise Server 12-LTSS (src):    java-1_7_0-openjdk-1.7.0.181-43.15.2
SUSE Linux Enterprise Desktop 12-SP3 (src):    java-1_7_0-openjdk-1.7.0.181-43.15.2
SUSE Enterprise Storage 4 (src):    java-1_7_0-openjdk-1.7.0.181-43.15.2
Comment 3 Swamp Workflow Management 2018-06-14 16:20:42 UTC
This is an autogenerated message for OBS integration:
This bug (1090026) was mentioned in
https://build.opensuse.org/request/show/616899 15.0 / java-1_8_0-openjdk
Comment 4 Swamp Workflow Management 2018-06-15 22:08:56 UTC
openSUSE-SU-2018:1710-1: An update that fixes 10 vulnerabilities is now available.

Category: security (important)
Bug References: 1090023,1090024,1090025,1090026,1090027,1090028,1090029,1090030,1090032,1090033
CVE References: CVE-2018-2790,CVE-2018-2794,CVE-2018-2795,CVE-2018-2796,CVE-2018-2797,CVE-2018-2798,CVE-2018-2799,CVE-2018-2800,CVE-2018-2814,CVE-2018-2815
Sources used:
openSUSE Leap 42.3 (src):    java-1_7_0-openjdk-1.7.0.181-51.1, java-1_7_0-openjdk-bootstrap-1.7.0.181-51.1
Comment 5 Swamp Workflow Management 2018-06-16 13:09:01 UTC
openSUSE-SU-2018:1719-1: An update that solves 10 vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1087066,1090023,1090024,1090025,1090026,1090027,1090028,1090029,1090030,1090032,1090033
CVE References: CVE-2018-2790,CVE-2018-2794,CVE-2018-2795,CVE-2018-2796,CVE-2018-2797,CVE-2018-2798,CVE-2018-2799,CVE-2018-2800,CVE-2018-2814,CVE-2018-2815
Sources used:
openSUSE Leap 42.3 (src):    java-1_8_0-openjdk-1.8.0.171-24.1
openSUSE Leap 15.0 (src):    java-1_8_0-openjdk-1.8.0.171-lp150.2.3.1
Comment 6 Swamp Workflow Management 2018-07-12 13:10:21 UTC
SUSE-SU-2018:1938-1: An update that solves 10 vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1087066,1090023,1090024,1090025,1090026,1090027,1090028,1090029,1090030,1090032,1090033
CVE References: CVE-2018-2790,CVE-2018-2794,CVE-2018-2795,CVE-2018-2796,CVE-2018-2797,CVE-2018-2798,CVE-2018-2799,CVE-2018-2800,CVE-2018-2814,CVE-2018-2815
Sources used:
SUSE Linux Enterprise Module for Legacy Software 15 (src):    java-1_8_0-openjdk-1.8.0.171-3.3.2
Comment 7 Swamp Workflow Management 2018-07-12 16:11:49 UTC
SUSE-SU-2018:1938-2: An update that solves 10 vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1087066,1090023,1090024,1090025,1090026,1090027,1090028,1090029,1090030,1090032,1090033
CVE References: CVE-2018-2790,CVE-2018-2794,CVE-2018-2795,CVE-2018-2796,CVE-2018-2797,CVE-2018-2798,CVE-2018-2799,CVE-2018-2800,CVE-2018-2814,CVE-2018-2815
Sources used:
SUSE Linux Enterprise Module for Legacy Software 15 (src):    java-1_8_0-openjdk-1.8.0.171-3.3.2
Comment 8 Swamp Workflow Management 2018-10-18 16:19:06 UTC
SUSE-SU-2018:1690-2: An update that solves 10 vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1087066,1090023,1090024,1090025,1090026,1090027,1090028,1090029,1090030,1090032,1090033
CVE References: CVE-2018-2790,CVE-2018-2794,CVE-2018-2795,CVE-2018-2796,CVE-2018-2797,CVE-2018-2798,CVE-2018-2799,CVE-2018-2800,CVE-2018-2814,CVE-2018-2815
Sources used:
SUSE Linux Enterprise Server 12-SP2-BCL (src):    java-1_8_0-openjdk-1.8.0.171-27.19.1
Comment 9 Swamp Workflow Management 2018-10-18 17:31:20 UTC
SUSE-SU-2018:1692-2: An update that fixes 10 vulnerabilities is now available.

Category: security (important)
Bug References: 1090023,1090024,1090025,1090026,1090027,1090028,1090029,1090030,1090032,1090033
CVE References: CVE-2018-2790,CVE-2018-2794,CVE-2018-2795,CVE-2018-2796,CVE-2018-2797,CVE-2018-2798,CVE-2018-2799,CVE-2018-2800,CVE-2018-2814,CVE-2018-2815
Sources used:
SUSE Linux Enterprise Server 12-SP2-BCL (src):    java-1_7_0-openjdk-1.7.0.181-43.15.2
Comment 10 Marcus Meissner 2019-06-08 16:24:09 UTC
released