Bug 1077755 - (CVE-2018-6192) VUL-0: CVE-2018-6192: In Artifex MuPDF 1.12.0, the pdf_read_new_xref function in pdf/pdf-xref.c allowsremote attackers to cause a denial of service (segmentation violation andapplication crash) via a crafted pdf file.
(CVE-2018-6192)
VUL-0: CVE-2018-6192: In Artifex MuPDF 1.12.0, the pdf_read_new_xref function...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Maintenance
Leap 42.3
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/198938/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-01-26 14:49 UTC by Victor Pereira
Modified: 2018-02-08 23:43 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Pereira 2018-01-26 14:49:09 UTC
CVE-2018-6192

In Artifex MuPDF 1.12.0, the pdf_read_new_xref function in pdf/pdf-xref.c allows
remote attackers to cause a denial of service (segmentation violation and
application crash) via a crafted pdf file.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-6192
http://www.cvedetails.com/cve/CVE-2018-6192/
https://bugs.ghostscript.com/show_bug.cgi?id=698916
Comment 1 Swamp Workflow Management 2018-02-02 15:50:14 UTC
This is an autogenerated message for OBS integration:
This bug (1077755) was mentioned in
https://build.opensuse.org/request/show/572054 42.3 / mupdf
Comment 2 Swamp Workflow Management 2018-02-02 21:20:15 UTC
This is an autogenerated message for OBS integration:
This bug (1077755) was mentioned in
https://build.opensuse.org/request/show/572115 42.3 / mupdf
Comment 3 Andreas Stieger 2018-02-08 18:33:55 UTC
release for Leap, done
Comment 4 Swamp Workflow Management 2018-02-08 23:09:03 UTC
openSUSE-SU-2018:0405-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1077407,1077755,1079100
CVE References: CVE-2018-6187,CVE-2018-6192,CVE-2018-6544
Sources used:
openSUSE Leap 42.3 (src):    mupdf-1.12.0-28.1