Bug 1083426 - (CVE-2018-7182) VUL-0: CVE-2018-7182: ntp: buffer read overrun leads information leak in ctl_getitem()
(CVE-2018-7182)
VUL-0: CVE-2018-7182: ntp: buffer read overrun leads information leak in ctl_...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/201015/
CVSSv3:RedHat:CVE-2018-7182:5.3:(AV:N...
:
Depends on:
Blocks: 1082210
  Show dependency treegraph
 
Reported: 2018-03-01 07:46 UTC by Johannes Segitz
Modified: 2018-10-18 17:30 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Segitz 2018-03-01 07:46:13 UTC
ctl_getitem() is used by ntpd to process incoming mode 6 packets. A malicious mode 6 packet can be sent to an ntpd instance, and if the ntpd instance is from 4.2.8p6 thru 4.2.8p10, that will cause ctl_getitem() to read past the end of its buffer.

References:
http://support.ntp.org/bin/view/Main/NtpBug3412
https://bugzilla.redhat.com/show_bug.cgi?id=1550208
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-7182
http://people.canonical.com/~ubuntu-security/cve/2018/CVE-2018-7182.html
Comment 1 Swamp Workflow Management 2018-03-14 09:40:30 UTC
This is an autogenerated message for OBS integration:
This bug (1083426) was mentioned in
https://build.opensuse.org/request/show/586702 Factory / ntp
Comment 4 Swamp Workflow Management 2018-03-22 09:03:58 UTC
An update workflow for this issue was started.
This issue was rated as moderate.
Please submit fixed packages until 2018-04-05.
When done, reassign the bug to security-team@suse.de.
https://swamp.suse.de/webswamp/wf/64004
Comment 5 Swamp Workflow Management 2018-03-26 13:12:37 UTC
SUSE-SU-2018:0808-1: An update that solves 6 vulnerabilities and has one errata is now available.

Category: security (moderate)
Bug References: 1077445,1082210,1083417,1083420,1083422,1083424,1083426
CVE References: CVE-2016-1549,CVE-2018-7170,CVE-2018-7182,CVE-2018-7183,CVE-2018-7184,CVE-2018-7185
Sources used:
SUSE Linux Enterprise Server 11-SP4 (src):    ntp-4.2.8p11-64.4.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    ntp-4.2.8p11-64.4.1
Comment 7 Swamp Workflow Management 2018-04-16 19:11:34 UTC
SUSE-SU-2018:0956-1: An update that solves 6 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1077445,1082063,1082210,1083417,1083420,1083422,1083424,1083426
CVE References: CVE-2016-1549,CVE-2018-7170,CVE-2018-7182,CVE-2018-7183,CVE-2018-7184,CVE-2018-7185
Sources used:
SUSE Linux Enterprise Server 12-SP3 (src):    ntp-4.2.8p11-64.3.2
SUSE Linux Enterprise Desktop 12-SP3 (src):    ntp-4.2.8p11-64.3.2
SUSE CaaS Platform ALL (src):    ntp-4.2.8p11-64.3.2
Comment 8 Swamp Workflow Management 2018-04-17 10:09:55 UTC
openSUSE-SU-2018:0970-1: An update that solves 6 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1077445,1082063,1082210,1083417,1083420,1083422,1083424,1083426
CVE References: CVE-2016-1549,CVE-2018-7170,CVE-2018-7182,CVE-2018-7183,CVE-2018-7184,CVE-2018-7185
Sources used:
openSUSE Leap 42.3 (src):    ntp-4.2.8p11-31.3.1
Comment 9 Swamp Workflow Management 2018-05-29 19:09:07 UTC
SUSE-SU-2018:1464-1: An update that solves 6 vulnerabilities and has three fixes is now available.

Category: security (moderate)
Bug References: 1034892,1077445,1082063,1082210,1083417,1083420,1083422,1083424,1083426
CVE References: CVE-2016-1549,CVE-2018-7170,CVE-2018-7182,CVE-2018-7183,CVE-2018-7184,CVE-2018-7185
Sources used:
SUSE Linux Enterprise Server 12-LTSS (src):    ntp-4.2.8p11-46.26.2
Comment 10 Swamp Workflow Management 2018-06-20 19:09:39 UTC
SUSE-SU-2018:1765-1: An update that solves 6 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1077445,1082063,1082210,1083417,1083420,1083422,1083424,1083426
CVE References: CVE-2016-1549,CVE-2018-7170,CVE-2018-7182,CVE-2018-7183,CVE-2018-7184,CVE-2018-7185
Sources used:
SUSE OpenStack Cloud 7 (src):    ntp-4.2.8p11-64.5.1
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    ntp-4.2.8p11-64.5.1
SUSE Linux Enterprise Server for SAP 12-SP1 (src):    ntp-4.2.8p11-64.5.1
SUSE Linux Enterprise Server 12-SP3 (src):    ntp-4.2.8p11-64.5.1
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    ntp-4.2.8p11-64.5.1
SUSE Linux Enterprise Server 12-SP1-LTSS (src):    ntp-4.2.8p11-64.5.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    ntp-4.2.8p11-64.5.1
SUSE Enterprise Storage 4 (src):    ntp-4.2.8p11-64.5.1
SUSE CaaS Platform ALL (src):    ntp-4.2.8p11-64.5.1
Comment 11 Marcus Meissner 2018-09-07 14:13:07 UTC
released
Comment 12 Swamp Workflow Management 2018-10-18 17:30:28 UTC
SUSE-SU-2018:1765-2: An update that solves 6 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1077445,1082063,1082210,1083417,1083420,1083422,1083424,1083426
CVE References: CVE-2016-1549,CVE-2018-7170,CVE-2018-7182,CVE-2018-7183,CVE-2018-7184,CVE-2018-7185
Sources used:
SUSE Linux Enterprise Server 12-SP2-BCL (src):    ntp-4.2.8p11-64.5.1