Bug 1082775 - (CVE-2018-7438) VUL-0: CVE-2018-7438: freexl: heap-buffer-overflow in freexl.c:383 parse_unicode_string
(CVE-2018-7438)
VUL-0: CVE-2018-7438: freexl: heap-buffer-overflow in freexl.c:383 parse_unic...
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 42.3
Other Other
: P3 - Medium : Minor (vote)
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/200786/
CVSSv3:RedHat:CVE-2018-7438:4.3:(AV:N...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-26 09:05 UTC by Karol Babioch
Modified: 2018-03-01 15:37 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karol Babioch 2018-02-26 09:05:56 UTC
rh#1547889

An issue was discovered in FreeXL before 1.0.5. There is a heap-based buffer
over-read in the parse_unicode_string function.

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1547889
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-7438
http://www.cvedetails.com/cve/CVE-2018-7438/
Comment 1 Swamp Workflow Management 2018-02-26 11:40:14 UTC
This is an autogenerated message for OBS integration:
This bug (1082775) was mentioned in
https://build.opensuse.org/request/show/580161 42.3 / freexl
https://build.opensuse.org/request/show/580163 Backports:SLE-12 / freexl
Comment 2 Andreas Stieger 2018-03-01 08:29:57 UTC
done
Comment 3 Swamp Workflow Management 2018-03-01 14:08:38 UTC
openSUSE-SU-2018:0569-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1082774,1082775,1082776,1082777,1082778
CVE References: CVE-2018-7435,CVE-2018-7436,CVE-2018-7437,CVE-2018-7438,CVE-2018-7439
Sources used:
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    freexl-1.0.5-8.1
Comment 4 Swamp Workflow Management 2018-03-01 14:09:30 UTC
openSUSE-SU-2018:0570-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1082774,1082775,1082776,1082777,1082778
CVE References: CVE-2018-7435,CVE-2018-7436,CVE-2018-7437,CVE-2018-7438,CVE-2018-7439
Sources used:
openSUSE Leap 42.3 (src):    freexl-1.0.5-8.1