Bug 1085296 - (CVE-2018-7729) VUL-1: CVE-2018-7729: exempi: Stack-based buffer overflow in XMPFiles/source/FileHandlers/PostScript_Handler.cpp:PostScript_MetaHandler::ParsePSFile() allows for denial of service
(CVE-2018-7729)
VUL-1: CVE-2018-7729: exempi: Stack-based buffer overflow in XMPFiles/source/...
Status: RESOLVED INVALID
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P5 - None : Minor
: ---
Assigned To: E-mail List
Security Team bot
https://smash.suse.de/issue/201342/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-14 13:28 UTC by Karol Babioch
Modified: 2018-04-05 10:50 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karol Babioch 2018-03-14 13:28:06 UTC
rh#1555160

An issue was discovered in Exempi through 2.4.4. There is a stack-based buffer
over-read in the PostScript_MetaHandler::ParsePSFile() function in
XMPFiles/source/FileHandlers/PostScript_Handler.cpp.

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1555160
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2018-7729
http://people.canonical.com/~ubuntu-security/cve/2018/CVE-2018-7729.html
http://www.cvedetails.com/cve/CVE-2018-7729/
https://bugs.freedesktop.org/show_bug.cgi?id=105206
https://cgit.freedesktop.org/exempi/commit/?id=baa4b8a02c1ffab9645d13f0bfb1c0d10d311a0c
Comment 1 Karol Babioch 2018-03-14 14:26:26 UTC
Only introduced with commit 4652015f in version 2.4.0. Does not affect our supported codestreams.
Comment 2 Karol Babioch 2018-03-14 14:28:20 UTC
Fixed in Factory: https://build.opensuse.org/request/show/586877