Bug 1134689 - (CVE-2019-10130) VUL-1: CVE-2019-10130: postgresql96,postgresql10,postgresql11: potential bypass of security policy allows a user to read restricted data
(CVE-2019-10130)
VUL-1: CVE-2019-10130: postgresql96,postgresql10,postgresql11: potential bypa...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/232475/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-05-10 09:24 UTC by Alexandros Toptsoglou
Modified: 2020-08-17 16:17 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandros Toptsoglou 2019-05-10 09:24:20 UTC
CVE-2019-10130

PostgreSQL maintains statistics for tables by sampling data available in columns; this data is consulted during the query planning process. Prior to this release, a user able to execute SQL queries with permissions to read a given column could craft a leaky operator that could read whatever data had been sampled from that column. If this happened to include values from rows that the user is forbidden to see by a row security policy, the user could effectively bypass the policy. This is fixed by only allowing a non-leakproof operator to use this data if there are no relevant row security policies for the table.

This issue is present in PostgreSQL 9.5, 9.6, 10, and 11. The

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-10130
http://www.debian.org/security/2019/dsa-4439
http://people.canonical.com/~ubuntu-security/cve/2019/CVE-2019-10130.html
Comment 1 Alexandros Toptsoglou 2019-05-10 09:31:08 UTC
The issue affects all codestreams that ship postgresql96, postgresql10 or postgresql11.
Specifically: 
SLE15 is affected --> postgresql10
SLE12 is affected --> postgresql10 and postgresql96
SLE11-SP1 is affected --> postgresql10
TW is affected --> postgresql11
Comment 2 Swamp Workflow Management 2019-05-13 17:30:12 UTC
This is an autogenerated message for OBS integration:
This bug (1134689) was mentioned in
https://build.opensuse.org/request/show/702689 Factory / postgresql11
Comment 3 Swamp Workflow Management 2019-05-16 15:00:08 UTC
This is an autogenerated message for OBS integration:
This bug (1134689) was mentioned in
https://build.opensuse.org/request/show/703450 Factory / postgresql10
https://build.opensuse.org/request/show/703451 Factory / postgresql95
Comment 5 Swamp Workflow Management 2019-05-16 15:40:07 UTC
This is an autogenerated message for OBS integration:
This bug (1134689) was mentioned in
https://build.opensuse.org/request/show/703461 Factory / postgresql96
Comment 6 Swamp Workflow Management 2019-06-14 19:11:45 UTC
SUSE-SU-2019:1511-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1134689
CVE References: CVE-2019-10130
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    postgresql10-libs-10.8-1.9.1
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    postgresql10-libs-10.8-1.9.1
SUSE Linux Enterprise Server 12-SP4 (src):    postgresql10-10.8-1.9.1, postgresql10-libs-10.8-1.9.1
SUSE Linux Enterprise Server 12-SP3 (src):    postgresql10-10.8-1.9.1, postgresql10-libs-10.8-1.9.1
SUSE Linux Enterprise Desktop 12-SP4 (src):    postgresql10-10.8-1.9.1, postgresql10-libs-10.8-1.9.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    postgresql10-10.8-1.9.1, postgresql10-libs-10.8-1.9.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2019-06-18 16:49:42 UTC
openSUSE-SU-2019:1578-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1134689
CVE References: CVE-2019-10130
Sources used:
openSUSE Leap 42.3 (src):    postgresql10-10.8-8.1, postgresql10-libs-10.8-8.1
Comment 9 Swamp Workflow Management 2019-06-24 16:14:59 UTC
SUSE-SU-2019:1687-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1134689
CVE References: CVE-2019-10130
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP3 (src):    postgresql96-libs-9.6.13-3.25.1
SUSE Linux Enterprise Server 12-SP3 (src):    postgresql96-9.6.13-3.25.1, postgresql96-libs-9.6.13-3.25.1
SUSE Linux Enterprise Desktop 12-SP3 (src):    postgresql96-9.6.13-3.25.1, postgresql96-libs-9.6.13-3.25.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2019-06-30 13:11:16 UTC
openSUSE-SU-2019:1668-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1134689
CVE References: CVE-2019-10130
Sources used:
openSUSE Leap 42.3 (src):    postgresql96-9.6.13-24.1, postgresql96-libs-9.6.13-24.1
Comment 11 Swamp Workflow Management 2019-07-10 16:13:15 UTC
SUSE-SU-2019:1810-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1134689,1138034
CVE References: CVE-2019-10130,CVE-2019-10164
Sources used:
SUSE Linux Enterprise Module for Server Applications 15 (src):    postgresql10-10.9-4.13.2
SUSE Linux Enterprise Module for Packagehub Subpackages 15 (src):    postgresql10-10.9-4.13.2
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    postgresql10-10.9-4.13.2
SUSE Linux Enterprise Module for Basesystem 15 (src):    postgresql10-10.9-4.13.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 12 Swamp Workflow Management 2019-07-21 10:19:25 UTC
openSUSE-SU-2019:1773-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1134689,1138034
CVE References: CVE-2019-10130,CVE-2019-10164
Sources used:
openSUSE Leap 15.1 (src):    postgresql10-10.9-lp151.2.3.1
openSUSE Leap 15.0 (src):    postgresql10-10.9-lp150.3.10.1
Comment 13 Swamp Workflow Management 2019-07-29 16:18:43 UTC
SUSE-SU-2019:2012-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1134689,1138034
CVE References: CVE-2019-10130,CVE-2019-10164
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP1 (src):    postgresql10-10.9-8.3.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (src):    postgresql10-10.9-8.3.1
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    postgresql10-10.9-8.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 14 Marcus Meissner 2019-11-15 07:12:59 UTC
done
Comment 15 OBSbugzilla Bot 2020-08-14 08:10:24 UTC
This is an autogenerated message for OBS integration:
This bug (1134689) was mentioned in
https://build.opensuse.org/request/show/826617 15.1+15.2+Backports:SLE-15-SP1+Backports:SLE-15-SP2 / postgresql96
Comment 16 Swamp Workflow Management 2020-08-17 16:17:47 UTC
openSUSE-SU-2020:1227-1: An update that solves 7 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1091610,1104199,1104202,1134689,1145092,1148643,1163985,1171924,1175194
CVE References: CVE-2018-10915,CVE-2018-10925,CVE-2018-1115,CVE-2019-10130,CVE-2019-10208,CVE-2020-14350,CVE-2020-1720
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    postgresql-12.0.1-lp151.6.9.1, postgresql10-10.13-lp151.2.14.1, postgresql12-12.3-lp151.2.1, postgresql96-9.6.19-lp151.3.3.1