Bug 1139802 - (CVE-2019-13045) VUL-1: CVE-2019-13045: Irssi 1.2.1/1.1.3/1.0.8: SASL use-after.-free
(CVE-2019-13045)
VUL-1: CVE-2019-13045: Irssi 1.2.1/1.1.3/1.0.8: SASL use-after.-free
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Other
Leap 42.3
Other Other
: P4 - Low : Minor (vote)
: ---
Assigned To: Ailin Nemui
Security Team bot
https://smash.suse.de/issue/235883/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-06-30 12:42 UTC by Marcus Meissner
Modified: 2019-08-14 22:38 UTC (History)
0 users

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Ailin Nemui 2019-07-01 07:31:01 UTC
I opened https://build.opensuse.org/request/show/712730
Comment 2 Swamp Workflow Management 2019-07-02 10:12:40 UTC
openSUSE-SU-2019:1690-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1139802
CVE References: CVE-2019-13045
Sources used:
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    irssi-1.1.3-33.1
Comment 3 Swamp Workflow Management 2019-07-02 10:14:24 UTC
openSUSE-SU-2019:1690-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1139802
CVE References: CVE-2019-13045
Sources used:
openSUSE Leap 42.3 (src):    irssi-1.1.3-33.1
openSUSE Leap 15.1 (src):    irssi-1.1.3-lp151.2.3.1
openSUSE Leap 15.0 (src):    irssi-1.1.3-lp150.33.1
openSUSE Backports SLE-15 (src):    irssi-1.1.3-bp150.33.1
SUSE Package Hub for SUSE Linux Enterprise 12 (src):    irssi-1.1.3-33.1
Comment 4 Tomáš Chvátal 2019-07-11 11:42:55 UTC
This is automated batch bugzilla cleanup.

The openSUSE 42.3 changed to end-of-life (EOL [1]) status. As such
it is no longer maintained, which means that it will not receive any
further security or bug fix updates.
As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
openSUSE (At this moment openSUSE Leap 15.1, 15.0 and Tumbleweed) please
feel free to reopen this bug against that version (!you must update the
"Version" component in the bug fields, do not just reopen please), or
alternatively create a new ticket.

Thank you for reporting this bug and we are sorry it could not be fixed
during the lifetime of the release.

[1] https://en.opensuse.org/Lifetime
Comment 5 Marcus Meissner 2019-07-11 13:54:30 UTC
actually state is "fixed"
Comment 6 Swamp Workflow Management 2019-08-14 22:10:19 UTC
openSUSE-SU-2019:1894-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1139802
CVE References: CVE-2019-13045
Sources used:
openSUSE Backports SLE-15-SP1 (src):    irssi-1.1.3-bp151.3.3.3