Bug 1177789 - (CVE-2019-14584) VUL-1: CVE-2019-14584: ovmf,shim: NULL pointer dereference in AuthenticodeVerify()
(CVE-2019-14584)
VUL-1: CVE-2019-14584: ovmf,shim: NULL pointer dereference in AuthenticodeVer...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/269405/
CVSSv3.1:SUSE:CVE-2019-14584:4.0:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-10-16 08:44 UTC by Marcus Meissner
Modified: 2021-09-24 13:26 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Meissner 2020-10-16 08:44:05 UTC
CVE-2019-14584

https://edk2.groups.io/g/devel/message/66309

https://bugzilla.tianocore.org/show_bug.cgi?id=1914

AuthenticodeVerify() calls OpenSSLs d2i_PKCS7() API to parse asn encoded signed authenticode pkcs#7 data. when this successfully returns, a type check is done by calling PKCS7_type_is_signed() and then Pkcs7->d.sign->contents->type is used. It is possible to construct an asn1 blob that successfully decodes and have d2i_PKCS7() return a valid pointer and have PKCS7_type_is_signed() also return success  but have Pkcs7->d.sign be a NULL pointer.
Comment 3 Gary Ching-Pang Lin 2020-11-30 09:25:21 UTC
The fix hit the edk2 git master and was included in stable202011. Will start to backport it.

(*) https://github.com/tianocore/edk2/commit/26442d11e620a9e81c019a24a4ff38441c64ba10
Comment 7 Gary Ching-Pang Lin 2020-12-03 08:15:53 UTC
The fix is submitted. Reassign the bug back to the security team.
Comment 8 Swamp Workflow Management 2020-12-18 20:15:11 UTC
SUSE-SU-2020:3885-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1177789
CVE References: CVE-2019-14584
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP1 (src):    ovmf-2017+git1510945757.b2662641d5-5.38.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 9 Swamp Workflow Management 2020-12-18 20:19:20 UTC
SUSE-SU-2020:3884-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1177789
CVE References: CVE-2019-14584
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP2 (src):    ovmf-201911-7.8.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2020-12-18 20:20:15 UTC
SUSE-SU-2020:3883-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1177789
CVE References: CVE-2019-14584
JIRA References: 
Sources used:
SUSE Linux Enterprise Server 12-SP5 (src):    ovmf-2017+git1510945757.b2662641d5-3.32.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2020-12-22 11:18:15 UTC
openSUSE-SU-2020:2314-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1177789
CVE References: CVE-2019-14584
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    ovmf-201911-lp152.6.8.1
Comment 12 Swamp Workflow Management 2020-12-26 23:22:55 UTC
openSUSE-SU-2020:2336-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1177789
CVE References: CVE-2019-14584
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    ovmf-2017+git1510945757.b2662641d5-lp151.11.12.1
Comment 16 OBSbugzilla Bot 2021-04-22 07:00:12 UTC
This is an autogenerated message for OBS integration:
This bug (1177789) was mentioned in
https://build.opensuse.org/request/show/887447 15.2 / shim
Comment 17 Swamp Workflow Management 2021-04-23 16:20:23 UTC
openSUSE-SU-2021:0598-1: An update that solves one vulnerability and has 7 fixes is now available.

Category: security (important)
Bug References: 1173411,1174512,1175509,1177315,1177404,1177789,1182057,1184454
CVE References: CVE-2019-14584
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    shim-15.4-lp152.4.8.1
Comment 19 Swamp Workflow Management 2021-06-22 16:26:16 UTC
SUSE-SU-2021:2117-1: An update that solves three vulnerabilities and has one errata is now available.

Category: security (important)
Bug References: 1177789,1183578,1183579,1186151
CVE References: CVE-2019-14584,CVE-2021-28210,CVE-2021-28211
JIRA References: 
Sources used:
SUSE Linux Enterprise Server 12-SP2-BCL (src):    ovmf-2015+git1462940744.321151f-19.23.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 22 Swamp Workflow Management 2021-09-24 13:21:26 UTC
SUSE-RU-2021:3224-1: An update that has 12 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1177315,1177789,1182057,1184454,1185232,1185261,1185441,1185464,1185621,1185961,1187260,1187696
CVE References: 
JIRA References: 
Sources used:
SUSE MicroOS 5.0 (src):    shim-15.4-3.32.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    shim-susesigned-15.4-3.10.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    shim-15.4-3.32.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 23 Swamp Workflow Management 2021-09-24 13:26:11 UTC
openSUSE-RU-2021:3224-1: An update that has 12 recommended fixes can now be installed.

Category: recommended (moderate)
Bug References: 1177315,1177789,1182057,1184454,1185232,1185261,1185441,1185464,1185621,1185961,1187260,1187696
CVE References: 
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    shim-susesigned-15.4-3.10.1