Bug 1153551 - (CVE-2019-17401) VUL-1: CVE-2019-17401: liblnk: heap-based buffer over-read in the network_share_name_offset>20
(CVE-2019-17401)
VUL-1: CVE-2019-17401: liblnk: heap-based buffer over-read in the network_sha...
Status: NEW
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.1
Other Other
: P4 - Low : Normal (vote)
: ---
Assigned To: Greg Freemyer
Security Team bot
https://smash.suse.de/issue/244507/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-10-10 08:49 UTC by Alexandros Toptsoglou
Modified: 2019-10-10 22:12 UTC (History)
0 users

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments
POC (668 bytes, application/octet-stream)
2019-10-10 08:50 UTC, Alexandros Toptsoglou
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandros Toptsoglou 2019-10-10 08:49:31 UTC
CVE-2019-17401

libyal liblnk 20191006 has a heap-based buffer over-read in the
network_share_name_offset>20 code block of liblnk_location_information_read_data
in liblnk_location_information.c, a different issue than CVE-2019-17264.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-17401
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-17401
https://github.com/libyal/liblnk/issues/40
Comment 1 Alexandros Toptsoglou 2019-10-10 08:50:37 UTC
Created attachment 821005 [details]
POC

Reproduce by valgrind lnkinfo -v $POC