Bug 1161436 - (CVE-2019-20386) VUL-1: CVE-2019-20386: systemd: memory leak in button_open in login/logind-button.c
(CVE-2019-20386)
VUL-1: CVE-2019-20386: systemd: memory leak in button_open in login/logind-bu...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/251457/
CVSSv3.1:SUSE:CVE-2019-20386:2.4:(AV...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-21 14:29 UTC by Wolfgang Frisch
Modified: 2020-07-13 15:00 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Frisch 2020-01-21 14:29:35 UTC
CVE-2019-20386

An issue was discovered in button_open in login/logind-button.c in systemd
before 243. When executing the udevadm trigger command, a memory leak may occur.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-20386
https://github.com/systemd/systemd/commit/b2774a3ae692113e1f47a336a6c09bac9cfb49ad
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-20386
Comment 5 Swamp Workflow Management 2020-02-06 14:13:24 UTC
SUSE-SU-2020:0335-1: An update that solves two vulnerabilities and has 12 fixes is now available.

Category: security (important)
Bug References: 1084671,1092920,1106383,1133495,1151377,1154256,1155207,1155574,1156213,1156482,1158485,1159814,1161436,1162108
CVE References: CVE-2019-20386,CVE-2020-1712
Sources used:
SUSE Linux Enterprise Server for SAP 15 (src):    systemd-234-24.39.1
SUSE Linux Enterprise Server 15-LTSS (src):    systemd-234-24.39.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (src):    systemd-234-24.39.1, systemd-mini-234-24.39.1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (src):    systemd-234-24.39.1, systemd-mini-234-24.39.1
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    systemd-234-24.39.1
SUSE Linux Enterprise Module for Basesystem 15 (src):    systemd-234-24.39.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    systemd-234-24.39.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    systemd-234-24.39.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2020-02-11 23:16:35 UTC
openSUSE-SU-2020:0208-1: An update that solves two vulnerabilities and has 12 fixes is now available.

Category: security (important)
Bug References: 1084671,1092920,1106383,1133495,1151377,1154256,1155207,1155574,1156213,1156482,1158485,1159814,1161436,1162108
CVE References: CVE-2019-20386,CVE-2020-1712
Sources used:
openSUSE Leap 15.1 (src):    systemd-234-lp151.26.7.1, systemd-mini-234-lp151.26.7.1
Comment 9 Swamp Workflow Management 2020-07-02 16:14:43 UTC
SUSE-SU-2020:1828-1: An update that solves one vulnerability and has 9 fixes is now available.

Category: security (moderate)
Bug References: 1084671,1154256,1157315,1161262,1161436,1162698,1164538,1165633,1167622,1171145
CVE References: CVE-2019-20386
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    systemd-228-157.12.5
SUSE Linux Enterprise Server 12-SP5 (src):    systemd-228-157.12.5

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2020-07-04 01:13:39 UTC
SUSE-SU-2020:1842-1: An update that solves one vulnerability and has 9 fixes is now available.

Category: security (moderate)
Bug References: 1084671,1154256,1157315,1161262,1161436,1162698,1164538,1165633,1167622,1171145
CVE References: CVE-2019-20386
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP4 (src):    systemd-228-150.86.3
SUSE Linux Enterprise Server 12-SP4 (src):    systemd-228-150.86.3

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Alexandros Toptsoglou 2020-07-13 15:00:56 UTC
Done