Bug 1161657 - (CVE-2019-20397) VUL-0: CVE-2019-20397: libyang: double-free in yyparse() when organization field is not terminated
(CVE-2019-20397)
VUL-0: CVE-2019-20397: libyang: double-free in yyparse() when organization fi...
Status: NEW
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Basesystem
Leap 15.2
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Martin Hauke
Security Team bot
https://smash.suse.de/issue/251563/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-23 08:49 UTC by Alexander Bergmann
Modified: 2020-02-19 20:14 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bergmann 2020-01-23 08:49:22 UTC
rh#1793928

A double-free is present in libyang up to version v1.0-r1 in function yyparse() when an organization field is not terminated. Applications that use libyang to parse untrusted input yang files may be vulnerable to this flaw, which would cause a crash or potentially code execution.

Upstream issue:
https://github.com/CESNET/libyang/issues/739

Upstream fix:
https://github.com/CESNET/libyang/commit/88bd6c548ba79bce176cd875e9b56e7e0ef4d8d4

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1793928
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-20397
https://github.com/CESNET/libyang/commit/88bd6c548ba79bce176cd875e9b56e7e0ef4d8d4
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-20397
https://github.com/CESNET/libyang/compare/v0.16-r3...v1.0-r1
https://github.com/CESNET/libyang/issues/739
Comment 1 Martin Hauke 2020-02-19 20:14:05 UTC
I have made an SR to update the package to the latest version 1.0.130
https://build.opensuse.org/request/show/775242