Bug 1129854 - (CVE-2019-9834) VUL-0: CVE-2019-9834: netdata: HTML injection of malicious code into an imported snapshot
(CVE-2019-9834)
VUL-0: CVE-2019-9834: netdata: HTML injection of malicious code into an impor...
Status: REOPENED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.1
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Nirmoy Das
Security Team bot
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2019-03-20 08:01 UTC by Karol Babioch
Modified: 2020-01-16 14:59 UTC (History)
2 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karol Babioch 2019-03-20 08:01:53 UTC
The Netdata web application through 1.13.0 allows remote attackers to inject
their own malicious HTML code into an imported snapshot, aka HTML Injection.
Successful exploitation will allow attacker-supplied HTML to run in the context
of the affected browser, potentially allowing the attacker to steal
authentication credentials or to control how the site is rendered to the user.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2019-9834
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9834
https://www.youtube.com/watch?v=zSG93yX0B8k
https://www.exploit-db.com/exploits/46545
Comment 1 Tomáš Chvátal 2019-07-11 11:40:32 UTC
This is automated batch bugzilla cleanup.

The openSUSE 42.3 changed to end-of-life (EOL [1]) status. As such
it is no longer maintained, which means that it will not receive any
further security or bug fix updates.
As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
openSUSE (At this moment openSUSE Leap 15.1, 15.0 and Tumbleweed) please
feel free to reopen this bug against that version (!you must update the
"Version" component in the bug fields, do not just reopen please), or
alternatively create a new ticket.

Thank you for reporting this bug and we are sorry it could not be fixed
during the lifetime of the release.

[1] https://en.opensuse.org/Lifetime
Comment 2 Marcus Meissner 2019-07-12 06:12:27 UTC
15.0 and 15.1 still unfixed, factory is fixed.