Bug 1173700 - (CVE-2020-14397) VUL-0: CVE-2020-14397: LibVNCServer: NULL pointer dereference in libvncserver/rfbregion.c
(CVE-2020-14397)
VUL-0: CVE-2020-14397: LibVNCServer: NULL pointer dereference in libvncserver...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/261722/
CVSSv3.1:SUSE:CVE-2020-14397:6.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-07-03 15:15 UTC by Alexandros Toptsoglou
Modified: 2021-09-17 10:40 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Alexandros Toptsoglou 2020-07-03 15:15:49 UTC
Tracked SLE11,SLE12,SLE15 as affected. No POC until this point.
Comment 2 Petr Gajdos 2020-07-08 07:58:51 UTC
Submitted for 15,12,11/LibVNCServer.

I believe all fixed.
Comment 5 Swamp Workflow Management 2020-07-15 13:27:36 UTC
SUSE-SU-2020:1922-1: An update that fixes 10 vulnerabilities is now available.

Category: security (important)
Bug References: 1173477,1173691,1173694,1173700,1173701,1173743,1173874,1173875,1173876,1173880
CVE References: CVE-2017-18922,CVE-2018-21247,CVE-2019-20839,CVE-2019-20840,CVE-2020-14397,CVE-2020-14398,CVE-2020-14399,CVE-2020-14400,CVE-2020-14401,CVE-2020-14402
Sources used:
SUSE Linux Enterprise Workstation Extension 15-SP2 (src):    LibVNCServer-0.9.10-4.22.1
SUSE Linux Enterprise Workstation Extension 15-SP1 (src):    LibVNCServer-0.9.10-4.22.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP2 (src):    LibVNCServer-0.9.10-4.22.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP1 (src):    LibVNCServer-0.9.10-4.22.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2020-07-17 16:23:00 UTC
SUSE-SU-2020:14424-1: An update that fixes 6 vulnerabilities is now available.

Category: security (important)
Bug References: 1173691,1173694,1173700,1173701,1173743,1173880
CVE References: CVE-2020-14397,CVE-2020-14398,CVE-2020-14399,CVE-2020-14400,CVE-2020-14401,CVE-2020-14402
Sources used:
SUSE Linux Enterprise Server 11-SP4-LTSS (src):    LibVNCServer-0.9.1-160.19.1
SUSE Linux Enterprise Point of Sale 11-SP3 (src):    LibVNCServer-0.9.1-160.19.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    LibVNCServer-0.9.1-160.19.1
SUSE Linux Enterprise Debuginfo 11-SP3 (src):    LibVNCServer-0.9.1-160.19.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2020-07-18 16:14:04 UTC
openSUSE-SU-2020:0988-1: An update that fixes 10 vulnerabilities is now available.

Category: security (important)
Bug References: 1173477,1173691,1173694,1173700,1173701,1173743,1173874,1173875,1173876,1173880
CVE References: CVE-2017-18922,CVE-2018-21247,CVE-2019-20839,CVE-2019-20840,CVE-2020-14397,CVE-2020-14398,CVE-2020-14399,CVE-2020-14400,CVE-2020-14401,CVE-2020-14402
Sources used:
openSUSE Leap 15.1 (src):    LibVNCServer-0.9.10-lp151.7.9.1
Comment 8 Swamp Workflow Management 2020-07-21 13:13:13 UTC
openSUSE-SU-2020:1025-1: An update that fixes 10 vulnerabilities is now available.

Category: security (important)
Bug References: 1173477,1173691,1173694,1173700,1173701,1173743,1173874,1173875,1173876,1173880
CVE References: CVE-2017-18922,CVE-2018-21247,CVE-2019-20839,CVE-2019-20840,CVE-2020-14397,CVE-2020-14398,CVE-2020-14399,CVE-2020-14400,CVE-2020-14401,CVE-2020-14402
Sources used:
openSUSE Leap 15.2 (src):    LibVNCServer-0.9.10-lp152.9.8.1
Comment 9 Swamp Workflow Management 2020-07-24 16:21:49 UTC
openSUSE-SU-2020:1056-1: An update that fixes 10 vulnerabilities is now available.

Category: security (important)
Bug References: 1173477,1173691,1173694,1173700,1173701,1173743,1173874,1173875,1173876,1173880
CVE References: CVE-2017-18922,CVE-2018-21247,CVE-2019-20839,CVE-2019-20840,CVE-2020-14397,CVE-2020-14398,CVE-2020-14399,CVE-2020-14400,CVE-2020-14401,CVE-2020-14402
Sources used:
openSUSE Leap 15.2 (src):    LibVNCServer-0.9.10-lp152.9.4.2
Comment 12 Swamp Workflow Management 2020-08-07 16:16:32 UTC
SUSE-SU-2020:2167-1: An update that fixes 12 vulnerabilities is now available.

Category: security (important)
Bug References: 1173477,1173691,1173694,1173700,1173701,1173743,1173874,1173875,1173876,1173880
CVE References: CVE-2017-18922,CVE-2018-21247,CVE-2019-20839,CVE-2019-20840,CVE-2020-14397,CVE-2020-14398,CVE-2020-14399,CVE-2020-14400,CVE-2020-14401,CVE-2020-14402,CVE-2020-14403,CVE-2020-14404
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    LibVNCServer-0.9.9-17.31.1
SUSE OpenStack Cloud Crowbar 8 (src):    LibVNCServer-0.9.9-17.31.1
SUSE OpenStack Cloud 9 (src):    LibVNCServer-0.9.9-17.31.1
SUSE OpenStack Cloud 8 (src):    LibVNCServer-0.9.9-17.31.1
SUSE OpenStack Cloud 7 (src):    LibVNCServer-0.9.9-17.31.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    LibVNCServer-0.9.9-17.31.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    LibVNCServer-0.9.9-17.31.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    LibVNCServer-0.9.9-17.31.1
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    LibVNCServer-0.9.9-17.31.1
SUSE Linux Enterprise Server 12-SP5 (src):    LibVNCServer-0.9.9-17.31.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    LibVNCServer-0.9.9-17.31.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    LibVNCServer-0.9.9-17.31.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    LibVNCServer-0.9.9-17.31.1
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    LibVNCServer-0.9.9-17.31.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    LibVNCServer-0.9.9-17.31.1
SUSE Enterprise Storage 5 (src):    LibVNCServer-0.9.9-17.31.1
HPE Helion Openstack 8 (src):    LibVNCServer-0.9.9-17.31.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 13 Alexandros Toptsoglou 2020-08-27 13:31:37 UTC
Done
Comment 14 OBSbugzilla Bot 2021-09-17 10:40:32 UTC
This is an autogenerated message for OBS integration:
This bug (1173700) was mentioned in
https://build.opensuse.org/request/show/919689 Factory / LibVNCServer