Bug 1179200 - (CVE-2020-25663) VUL-0: CVE-2020-25663: ImageMagick: heap-buffer-overflow triggered by GetPixelRed, GetPixelBlue
(CVE-2020-25663)
VUL-0: CVE-2020-25663: ImageMagick: heap-buffer-overflow triggered by GetPixe...
Status: RESOLVED UPSTREAM
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Petr Gajdos
Security Team bot
https://smash.suse.de/issue/272299/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-11-25 13:48 UTC by Alexandros Toptsoglou
Modified: 2020-11-27 19:50 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandros Toptsoglou 2020-11-25 13:48:56 UTC
CVE-2020-25663

In ImageMagick, there is a heap-use-after-free at MagickCore/pixel-accessor.h:378:10 in GetPixelRed.

Reference:
https://github.com/ImageMagick/ImageMagick/issues/1723

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1891601
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-25663
Comment 1 Alexandros Toptsoglou 2020-11-25 13:49:17 UTC
Additional Reference 

https://github.com/ImageMagick/ImageMagick/issues/1724
Comment 2 Alexandros Toptsoglou 2020-11-25 13:50:20 UTC
The POC is unavailable.
Comment 3 Alexandros Toptsoglou 2020-11-27 19:50:09 UTC
The vulnerable logic firstly introduced at [1] and later revised in [2]. None of this commits exist in our Imagemagick


[1]https://github.com/ImageMagick/ImageMagick/commit/0c69c477e65d2a2695278ca614ffb9a3385137bc
[2]https://github.com/ImageMagick/ImageMagick/commit/8ed707a93fc4c7b3193dd562f07c4a1cc63cc19d