Bug 1179413 - (CVE-2020-26232) VUL-1: CVE-2020-26232: jupyter: open redirect vulnerability
(CVE-2020-26232)
VUL-1: CVE-2020-26232: jupyter: open redirect vulnerability
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.2
Other Other
: P4 - Low : Minor (vote)
: ---
Assigned To: Todd R
Security Team bot
https://smash.suse.de/issue/272226/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-11-30 12:07 UTC by Robert Frohl
Modified: 2021-10-29 10:32 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2020-11-30 12:07:06 UTC
CVE-2020-26232

Jupyter Server before version 1.0.6 has an Open redirect vulnerability. A
maliciously crafted link to a jupyter server could redirect the browser to a
different website. All jupyter servers are technically affected, however, these
maliciously crafted links can only be reasonably made for known jupyter server
hosts. A link to your jupyter server may appear safe, but ultimately redirect to
a spoofed server on the public internet.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-26232
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-26232
https://github.com/jupyter/jupyter_server/security/advisories/GHSA-grfj-wjv9-4f9v
https://github.com/jupyter-server/jupyter_server/blob/master/CHANGELOG.md#106---2020-11-18
https://github.com/jupyter-server/jupyter_server/commit/3d83e49090289c431da253e2bdb8dc479cbcb157
Comment 1 Robert Frohl 2020-11-30 12:07:50 UTC
seems to affect Leap15.2 and Tumbleweed.
Comment 2 Benjamin Greiner 2021-10-29 10:32:52 UTC
TW has a newer version and there is no jupyter-server in Leap 15.2 or 15.3