Bug 1180046 - (CVE-2020-27845) VUL-1: CVE-2020-27845: openjpeg,ghostscript-library,ghostscript,openjpeg2: heap-based buffer over-read in functions opj_pi_next_rlcp, opj_pi_next_rpcl and opj_pi_next_lrcp in openjp2/pi.c
(CVE-2020-27845)
VUL-1: CVE-2020-27845: openjpeg,ghostscript-library,ghostscript,openjpeg2: he...
Status: IN_PROGRESS
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/273308/
CVSSv3.1:SUSE:CVE-2020-27845:4.8:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-15 09:48 UTC by Wolfgang Frisch
Modified: 2022-11-18 20:30 UTC (History)
4 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Frisch 2020-12-15 09:48:56 UTC
CVE-2020-27845

A flaw was found in OpenJPEG. Specially crafted input file can lead to a heap-based buffer overflow in functions opj_pi_next_rlcp, opj_pi_next_rpcl and opj_pi_next_lrcp in openjp2/pi.c.

References:
https://github.com/uclouvain/openjpeg/issues/1302
https://bugzilla.redhat.com/show_bug.cgi?id=1907523
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2020-27845
Comment 1 Wolfgang Frisch 2020-12-15 17:17:00 UTC
Reproducer:
./bin/opj_compress -i ../100898689-fcf0b080-34fb-11eb-98bc-ec3466b9a527.png -o ./a.j2c -p RPCL -POC T1=2,2,2,2,2,RLCP  -TP L

>==23818==ERROR: AddressSanitizer: heap-buffer-overflow on address 0x608000000888 at pc 0x7f958cf16a12 bp 0x7ffe01d65080 sp 0x7ffe01d65078
>READ of size 4 at 0x608000000888 thread T0

The bug is reproducible in all supported code streams:
SUSE:SLE-12:Update      ghostscript  Affected
SUSE:SLE-12-SP2:Update  openjpeg2    Affected
SUSE:SLE-15:Update      ghostscript  Affected
SUSE:SLE-15:Update      openjpeg     Affected
SUSE:SLE-15:Update      openjpeg2    Affected
Comment 2 Gabriele Sonnu 2022-01-12 09:27:01 UTC
Hi, any update on this?
Comment 4 Thomas Leroy 2022-04-14 13:14:56 UTC
@Hans, is SUSE:SLE-15:Update/openjpeg affected here?
Comment 5 Gabriele Sonnu 2022-09-16 09:16:57 UTC
We decided to WONTFIX the embedded openjpeg2 in ghostscript, since backporting the patches or compiling it with the system openjpeg2 could likely cause regressions.

@Hans, we are still missing submissions for:

- SUSE:SLE-15:Update/openjpeg
- SUSE:SLE-12-SP2:Update/openjpeg2
- SUSE:SLE-15:Update/openjpeg2
Comment 7 Swamp Workflow Management 2022-10-27 19:27:50 UTC
SUSE-SU-2022:3801-1: An update that fixes 5 vulnerabilities is now available.

Category: security (important)
Bug References: 1149789,1179821,1180043,1180044,1180046
CVE References: CVE-2018-21010,CVE-2020-27824,CVE-2020-27842,CVE-2020-27843,CVE-2020-27845
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    openjpeg2-2.1.0-4.18.2
SUSE OpenStack Cloud 9 (src):    openjpeg2-2.1.0-4.18.2
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    openjpeg2-2.1.0-4.18.2
SUSE Linux Enterprise Server 12-SP5 (src):    openjpeg2-2.1.0-4.18.2
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    openjpeg2-2.1.0-4.18.2
SUSE Linux Enterprise Server 12-SP3-BCL (src):    openjpeg2-2.1.0-4.18.2
SUSE Linux Enterprise Server 12-SP2-BCL (src):    openjpeg2-2.1.0-4.18.2

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2022-10-27 19:30:44 UTC
SUSE-SU-2022:3802-1: An update that fixes 8 vulnerabilities is now available.

Category: security (important)
Bug References: 1140205,1149789,1179594,1179821,1180042,1180043,1180044,1180046
CVE References: CVE-2018-20846,CVE-2018-21010,CVE-2020-27814,CVE-2020-27824,CVE-2020-27841,CVE-2020-27842,CVE-2020-27843,CVE-2020-27845
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    openjpeg2-2.3.0-150000.3.8.1
openSUSE Leap 15.3 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Manager Server 4.1 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Manager Retail Branch Server 4.1 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Manager Proxy 4.1 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise Server for SAP 15 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise Server 15-LTSS (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Enterprise Storage 7 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE Enterprise Storage 6 (src):    openjpeg2-2.3.0-150000.3.8.1
SUSE CaaS Platform 4.0 (src):    openjpeg2-2.3.0-150000.3.8.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 9 Swamp Workflow Management 2022-11-18 20:30:33 UTC
SUSE-SU-2022:4082-1: An update that fixes 6 vulnerabilities is now available.

Category: security (important)
Bug References: 1140205,1149789,1179821,1180043,1180044,1180046
CVE References: CVE-2018-20846,CVE-2018-21010,CVE-2020-27824,CVE-2020-27842,CVE-2020-27843,CVE-2020-27845
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    openjpeg-1.5.2-150000.4.10.1
openSUSE Leap 15.3 (src):    openjpeg-1.5.2-150000.4.10.1
SUSE Linux Enterprise Server for SAP 15 (src):    openjpeg-1.5.2-150000.4.10.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    openjpeg-1.5.2-150000.4.10.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    openjpeg-1.5.2-150000.4.10.1
SUSE Linux Enterprise Server 15-LTSS (src):    openjpeg-1.5.2-150000.4.10.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (src):    openjpeg-1.5.2-150000.4.10.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    openjpeg-1.5.2-150000.4.10.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    openjpeg-1.5.2-150000.4.10.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    openjpeg-1.5.2-150000.4.10.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    openjpeg-1.5.2-150000.4.10.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    openjpeg-1.5.2-150000.4.10.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.