Bug 1179516 - (CVE-2020-29571) VUL-0: CVE-2020-29571: xen: FIFO event channels control structure ordering (XSA-359 v3)
(CVE-2020-29571)
VUL-0: CVE-2020-29571: xen: FIFO event channels control structure ordering (X...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/272615/
CVSSv3.1:SUSE:CVE-2020-29571:6.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2020-12-02 09:53 UTC by Robert Frohl
Modified: 2021-01-22 21:03 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 4 Wolfgang Frisch 2020-12-15 13:18:43 UTC
via oss-security:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

            Xen Security Advisory CVE-2020-29571 / XSA-359
                               version 3

            FIFO event channels control structure ordering

UPDATES IN VERSION 3
====================

Public release.

ISSUE DESCRIPTION
=================

A bounds check common to most operation time functions specific to FIFO
event channels depends on the CPU observing consistent state.  While the
producer side uses appropriately ordered writes, the consumer side isn't
protected against re-ordered reads, and may hence end up de-referencing
a NULL pointer.

IMPACT
======

Malicious or buggy guest kernels can mount a Denial of Service (DoS)
attack affecting the entire system.

VULNERABLE SYSTEMS
==================

All Xen versions from 4.4 onwards are vulnerable.  Xen versions 4.3 and
earlier are not vulnerable.

Only Arm systems may be vulnerable.  Whether a system is vulnerable will
depend on the specific CPU.  x86 systems are not vulnerable.

MITIGATION
==========

There is no known mitigation.

CREDITS
=======

This issue was discovered by Julien Grall of Amazon.

RESOLUTION
==========

Applying the attached patch resolves this issue.

Note that patches for released versions are generally prepared to
apply to the stable branches, and may not apply cleanly to the most
recent release tarball.  Downstreams are encouraged to update to the
tip of the stable branch before applying these patches.

xsa359.patch           xen-unstable - 4.10

$ sha256sum xsa359*
cb009ad77d1a3d8044431b2af568dd9dffefe07fc9f537fb6b53c2ec57aa77b7  xsa359.meta
3126d9304b68be84a89c42c223227c8f96ecbb96a0385a7e1bdc65ae5e0f344f  xsa359.patch
$

DEPLOYMENT DURING EMBARGO
=========================

Deployment of the patches and/or mitigations described above (or
others which are substantially similar) is permitted during the
embargo, even on public-facing systems with untrusted guest users and
administrators.

But: Distribution of updated software is prohibited (except to other
members of the predisclosure list).

Predisclosure list members who wish to deploy significantly different
patches and/or mitigations, please contact the Xen Project Security
Team.

(Note: this during-embargo deployment notice is retained in
post-embargo publicly released Xen Project advisories, even though it
is then no longer applicable.  This is to enable the community to have
oversight of the Xen Project Security Team's decisionmaking.)

For more information about permissible uses of embargoed information,
consult the Xen Project community's agreed Security Policy:
  http://www.xenproject.org/security-policy.html
-----BEGIN PGP SIGNATURE-----

iQFABAEBCAAqFiEEI+MiLBRfRHX6gGCng/4UyVfoK9kFAl/YqeAMHHBncEB4ZW4u
b3JnAAoJEIP+FMlX6CvZt6wIAJhvfVB8eRr5fqCbMUjZ++KKoG0AF/hoS7YRHiDn
zCgK/ff5RkY/pHHkVnrSOQeQg88SPBp/HaYljUXhoANbhXVxlt383QxQb63JwanR
1c3Sdvv5w0HdvrDyUMV16W/Edf/DGlSgciG/2saNz8pPbqiGKzeY3Q7nj3T3vLAE
ouNlHb2NItalKB2AdC62y/BFIjsn66G/P1agxyrcGirJxdvzORBx+LY7VTFOrOEB
L7yb8Y0U6Nj1XjGUXYm4X4xCCm+940Xc0Ht9zkDJlb3xSdO5sOtBE+Cx3F4uXn1c
vTMiKziAOgEKKXWV7P3KSWR/7G1aTm2YVRMy5XWtS6GY5D0=
=uRRE
-----END PGP SIGNATURE-----
Comment 5 Swamp Workflow Management 2020-12-16 20:19:08 UTC
SUSE-SU-2020:14578-1: An update that fixes 8 vulnerabilities is now available.

Category: security (moderate)
Bug References: 1179477,1179496,1179498,1179501,1179502,1179506,1179514,1179516
CVE References: CVE-2020-29130,CVE-2020-29480,CVE-2020-29481,CVE-2020-29483,CVE-2020-29484,CVE-2020-29566,CVE-2020-29570,CVE-2020-29571
JIRA References: 
Sources used:
SUSE Linux Enterprise Server 11-SP4-LTSS (src):    xen-4.4.4_48-61.61.1
SUSE Linux Enterprise Debuginfo 11-SP4 (src):    xen-4.4.4_48-61.61.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2020-12-18 20:21:54 UTC
SUSE-SU-2020:3881-1: An update that solves 7 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1027519,1176782,1179496,1179498,1179501,1179502,1179506,1179514,1179516
CVE References: CVE-2020-29480,CVE-2020-29481,CVE-2020-29483,CVE-2020-29484,CVE-2020-29566,CVE-2020-29570,CVE-2020-29571
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP1 (src):    xen-4.12.4_06-3.40.1
SUSE Linux Enterprise Module for Basesystem 15-SP1 (src):    xen-4.12.4_06-3.40.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2020-12-18 20:23:45 UTC
SUSE-SU-2020:3880-1: An update that solves 9 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1027519,1163019,1176782,1179477,1179496,1179498,1179501,1179502,1179506,1179514,1179516
CVE References: CVE-2020-29130,CVE-2020-29480,CVE-2020-29481,CVE-2020-29483,CVE-2020-29484,CVE-2020-29566,CVE-2020-29570,CVE-2020-29571,CVE-2020-8608
JIRA References: 
Sources used:
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    xen-4.12.4_06-3.36.1
SUSE Linux Enterprise Server 12-SP5 (src):    xen-4.12.4_06-3.36.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 9 Swamp Workflow Management 2020-12-22 11:16:28 UTC
openSUSE-SU-2020:2313-1: An update that solves 7 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1027519,1176782,1179496,1179498,1179501,1179502,1179506,1179514,1179516
CVE References: CVE-2020-29480,CVE-2020-29481,CVE-2020-29483,CVE-2020-29484,CVE-2020-29566,CVE-2020-29570,CVE-2020-29571
JIRA References: 
Sources used:
openSUSE Leap 15.1 (src):    xen-4.12.4_06-lp151.2.36.1
Comment 10 Swamp Workflow Management 2020-12-22 17:22:41 UTC
SUSE-SU-2020:3916-1: An update that solves 7 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1027519,1176782,1179496,1179498,1179501,1179502,1179506,1179514,1179516
CVE References: CVE-2020-29480,CVE-2020-29481,CVE-2020-29483,CVE-2020-29484,CVE-2020-29566,CVE-2020-29570,CVE-2020-29571
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 15 (src):    xen-4.10.4_24-3.53.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    xen-4.10.4_24-3.53.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    xen-4.10.4_24-3.53.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2020-12-22 17:24:27 UTC
SUSE-SU-2020:3913-1: An update that solves 8 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1027519,1176782,1179477,1179496,1179498,1179501,1179502,1179506,1179514,1179516
CVE References: CVE-2020-29130,CVE-2020-29480,CVE-2020-29481,CVE-2020-29483,CVE-2020-29484,CVE-2020-29566,CVE-2020-29570,CVE-2020-29571
JIRA References: 
Sources used:
SUSE OpenStack Cloud 7 (src):    xen-4.7.6_14-43.73.1
SUSE Linux Enterprise Server for SAP 12-SP2 (src):    xen-4.7.6_14-43.73.1
SUSE Linux Enterprise Server 12-SP2-LTSS (src):    xen-4.7.6_14-43.73.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    xen-4.7.6_14-43.73.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 12 Swamp Workflow Management 2020-12-22 17:26:13 UTC
SUSE-SU-2020:3914-1: An update that solves 8 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1027519,1176782,1179477,1179496,1179498,1179501,1179502,1179506,1179514,1179516
CVE References: CVE-2020-29130,CVE-2020-29480,CVE-2020-29481,CVE-2020-29483,CVE-2020-29484,CVE-2020-29566,CVE-2020-29570,CVE-2020-29571
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    xen-4.11.4_16-2.48.1
SUSE OpenStack Cloud 9 (src):    xen-4.11.4_16-2.48.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    xen-4.11.4_16-2.48.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    xen-4.11.4_16-2.48.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 13 Swamp Workflow Management 2020-12-22 17:29:31 UTC
SUSE-SU-2020:3915-1: An update that solves 7 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1027519,1176782,1179496,1179498,1179501,1179502,1179506,1179514,1179516
CVE References: CVE-2020-29480,CVE-2020-29481,CVE-2020-29483,CVE-2020-29484,CVE-2020-29566,CVE-2020-29570,CVE-2020-29571
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP2 (src):    xen-4.13.2_06-3.22.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    xen-4.13.2_06-3.22.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 14 Swamp Workflow Management 2020-12-26 11:17:14 UTC
openSUSE-SU-2020:2331-1: An update that solves 7 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1027519,1176782,1179496,1179498,1179501,1179502,1179506,1179514,1179516
CVE References: CVE-2020-29480,CVE-2020-29481,CVE-2020-29483,CVE-2020-29484,CVE-2020-29566,CVE-2020-29570,CVE-2020-29571
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    xen-4.13.2_06-lp152.2.21.1
Comment 15 Swamp Workflow Management 2020-12-29 17:17:14 UTC
SUSE-SU-2020:3945-1: An update that solves 8 vulnerabilities and has two fixes is now available.

Category: security (moderate)
Bug References: 1027519,1176782,1179477,1179496,1179498,1179501,1179502,1179506,1179514,1179516
CVE References: CVE-2020-29130,CVE-2020-29480,CVE-2020-29481,CVE-2020-29483,CVE-2020-29484,CVE-2020-29566,CVE-2020-29570,CVE-2020-29571
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 8 (src):    xen-4.9.4_16-3.80.1
SUSE OpenStack Cloud 8 (src):    xen-4.9.4_16-3.80.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    xen-4.9.4_16-3.80.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    xen-4.9.4_16-3.80.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    xen-4.9.4_16-3.80.1
SUSE Enterprise Storage 5 (src):    xen-4.9.4_16-3.80.1
HPE Helion Openstack 8 (src):    xen-4.9.4_16-3.80.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 18 Charles Arnold 2021-01-22 21:03:15 UTC
Backported and released to 11-SP3.