Bug 1184155 - (CVE-2021-1788) VUL-0: CVE-2021-1788,CVE-2021-1844,CVE-2021-1871: webkit2gtk3: WebKitGTK and WPE WebKit Security Advisory WSA-2021-0003
(CVE-2021-1788)
VUL-0: CVE-2021-1788,CVE-2021-1844,CVE-2021-1871: webkit2gtk3: WebKitGTK and ...
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
CVSSv3.1:SUSE:CVE-2021-1765:6.5:(AV:N...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-03-30 09:36 UTC by Alexandros Toptsoglou
Modified: 2022-04-11 08:10 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandros Toptsoglou 2021-03-30 09:36:39 UTC
------------------------------------------------------------------------
WebKitGTK and WPE WebKit Security Advisory                 WSA-2021-0003
------------------------------------------------------------------------

Date reported           : March 29, 2021
Advisory ID             : WSA-2021-0003
WebKitGTK Advisory URL  : https://webkitgtk.org/security/WSA-2021-0003.html
WPE WebKit Advisory URL : https://wpewebkit.org/security/WSA-2021-0003.html
CVE identifiers         : CVE-2021-1788, CVE-2021-1844, CVE-2021-1871.

Several vulnerabilities were discovered in WebKitGTK and WPE WebKit.

CVE-2021-1788
    Versions affected: WebKitGTK before 2.32.0 and WPE WebKit before 2.32.0.
    Credit to Francisco Alonso (@revskills).
    Impact: Processing maliciously crafted web content may lead to
    arbitrary code execution. Description: A use after free issue was
    addressed with improved memory management.

CVE-2021-1844
    Versions affected: WebKitGTK before 2.32.0 and WPE WebKit before 2.32.0.
    Credit to Clément Lecigne of Google’s Threat Analysis Group, Alison
    Huffman of Microsoft Browser Vulnerability Research.
    Impact: Processing maliciously crafted web content may lead to
    arbitrary code execution. Description: A memory corruption issue was
    addressed with improved validation.

CVE-2021-1871
    Versions affected: WebKitGTK before 2.32.0 and WPE WebKit before 2.32.0.
    Credit to an anonymous researcher.
    Impact: A remote attacker may be able to cause arbitrary code
    execution. Apple is aware of a report that this issue may have been
    actively exploited. Description: A logic issue was addressed with
    improved restrictions.


We recommend updating to the latest stable versions of WebKitGTK and WPE
WebKit. It is the best way to ensure that you are running safe versions
of WebKit. Please check our websites for information about the latest
stable releases.

Further information about WebKitGTK and WPE WebKit security advisories
can be found at: https://webkitgtk.org/security.html or
https://wpewebkit.org/security/.

The WebKitGTK and WPE WebKit team,
March 29, 2021
Comment 2 OBSbugzilla Bot 2021-04-12 13:00:08 UTC
This is an autogenerated message for OBS integration:
This bug (1184155) was mentioned in
https://build.opensuse.org/request/show/884649 Factory / webkit2gtk3
Comment 4 Swamp Workflow Management 2021-04-29 13:20:30 UTC
SUSE-SU-2021:1430-1: An update that fixes 10 vulnerabilities is now available.

Category: security (important)
Bug References: 1182719,1184155,1184262
CVE References: CVE-2020-27918,CVE-2020-29623,CVE-2021-1765,CVE-2021-1788,CVE-2021-1789,CVE-2021-1799,CVE-2021-1801,CVE-2021-1844,CVE-2021-1870,CVE-2021-1871
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    webkit2gtk3-2.32.0-3.15.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (src):    webkit2gtk3-2.32.0-3.15.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    webkit2gtk3-2.32.0-3.15.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    webkit2gtk3-2.32.0-3.15.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2021-05-01 01:23:05 UTC
openSUSE-SU-2021:0637-1: An update that fixes 10 vulnerabilities is now available.

Category: security (important)
Bug References: 1182719,1184155,1184262
CVE References: CVE-2020-27918,CVE-2020-29623,CVE-2021-1765,CVE-2021-1788,CVE-2021-1789,CVE-2021-1799,CVE-2021-1801,CVE-2021-1844,CVE-2021-1870,CVE-2021-1871
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    webkit2gtk3-2.32.0-lp152.2.13.1
Comment 6 Swamp Workflow Management 2021-05-04 19:24:52 UTC
SUSE-SU-2021:1499-1: An update that fixes 10 vulnerabilities is now available.

Category: security (important)
Bug References: 1182719,1184155,1184262
CVE References: CVE-2020-27918,CVE-2020-29623,CVE-2021-1765,CVE-2021-1788,CVE-2021-1789,CVE-2021-1799,CVE-2021-1801,CVE-2021-1844,CVE-2021-1870,CVE-2021-1871
JIRA References: 
Sources used:
SUSE Manager Server 4.0 (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Manager Retail Branch Server 4.0 (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Manager Proxy 4.0 (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Linux Enterprise Server for SAP 15 (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Linux Enterprise Server 15-LTSS (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    webkit2gtk3-2.32.0-3.74.1
SUSE Enterprise Storage 6 (src):    webkit2gtk3-2.32.0-3.74.1
SUSE CaaS Platform 4.0 (src):    webkit2gtk3-2.32.0-3.74.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 12 Swamp Workflow Management 2021-06-17 13:19:20 UTC
SUSE-SU-2021:1990-1: An update that fixes 17 vulnerabilities is now available.

Category: security (important)
Bug References: 1177087,1179122,1179451,1182286,1184155,1184262
CVE References: CVE-2020-13543,CVE-2020-13558,CVE-2020-13584,CVE-2020-27918,CVE-2020-29623,CVE-2020-9947,CVE-2020-9948,CVE-2020-9951,CVE-2020-9983,CVE-2021-1765,CVE-2021-1788,CVE-2021-1789,CVE-2021-1799,CVE-2021-1801,CVE-2021-1844,CVE-2021-1870,CVE-2021-1871
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    webkit2gtk3-2.32.1-2.63.3
SUSE OpenStack Cloud Crowbar 8 (src):    webkit2gtk3-2.32.1-2.63.3
SUSE OpenStack Cloud 9 (src):    webkit2gtk3-2.32.1-2.63.3
SUSE OpenStack Cloud 8 (src):    webkit2gtk3-2.32.1-2.63.3
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    webkit2gtk3-2.32.1-2.63.3
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    webkit2gtk3-2.32.1-2.63.3
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    webkit2gtk3-2.32.1-2.63.3
SUSE Linux Enterprise Server 12-SP5 (src):    webkit2gtk3-2.32.1-2.63.3
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    webkit2gtk3-2.32.1-2.63.3
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    webkit2gtk3-2.32.1-2.63.3
SUSE Linux Enterprise Server 12-SP3-BCL (src):    webkit2gtk3-2.32.1-2.63.3
SUSE Linux Enterprise Server 12-SP2-BCL (src):    webkit2gtk3-2.32.1-2.63.3
HPE Helion Openstack 8 (src):    webkit2gtk3-2.32.1-2.63.3

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 14 Gabriele Sonnu 2022-04-11 08:10:56 UTC
Done.