Bug 1182325 - (CVE-2021-20244) VUL-0: CVE-2021-20244: ImageMagick: Division by zero in ImplodeImage in MagickCore/visual-effects.c
(CVE-2021-20244)
VUL-0: CVE-2021-20244: ImageMagick: Division by zero in ImplodeImage in Magic...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/277979/
CVSSv3.1:SUSE:CVE-2021-20244:5.3:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-02-16 15:20 UTC by Gianluca Gabrielli
Modified: 2022-09-08 11:20 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gianluca Gabrielli 2021-02-16 15:20:50 UTC
CVE-2021-20244

A flaw was found in ImageMagick in MagickCore/visual-effects.c. An attacker who submits a crafted file that is processed by ImageMagick could trigger undefined behavior in the form of math division by zero. This would most likely lead to an impact to application availability, but could potentially cause other problems related to undefined behavior.

References:

https://github.com/ImageMagick/ImageMagick/pull/3194

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1928959
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-20244
Comment 1 Gianluca Gabrielli 2021-02-16 15:25:17 UTC
Affected codestreams:

 * SUSE:SLE-15:Update
 * SUSE:SLE-15-SP2:Update

Upstream patches:

 * https://github.com/ImageMagick/ImageMagick/commit/329dd528ab79531d884c0ba131e97d43f872ab5d.patch

Please notice that the patch won't directly apply to the ImageMagick-7.0.7-34, but some lines are present anyway on the codebase, for instance:

> ./ImageMagick-7.0.7-34/MagickCore/fx.c:3404:
> factor=pow(sin(MagickPI*sqrt((double) distance)/radius/2),-amount);
Comment 3 Petr Gajdos 2021-02-23 08:27:07 UTC
There is no testcase.
Comment 5 Petr Gajdos 2021-02-23 10:29:23 UTC
(In reply to Petr Gajdos from comment #4)
> ImageMagick6 commit:
> https://github.com/ImageMagick/ImageMagick6/commit/
> 53cb91b3e7bf95d0e372cbc745e0055ac6054745

(part of it)
Comment 6 Petr Gajdos 2021-02-23 10:29:41 UTC
Will submit for 15,12,11/ImageMagick.
Comment 7 Petr Gajdos 2021-02-23 11:29:20 UTC
Will submit for 15sp2,15,12,11/ImageMagick.
Comment 8 Petr Gajdos 2021-02-23 12:14:34 UTC
I believe all fixed.
Comment 10 Swamp Workflow Management 2021-02-25 17:17:34 UTC
SUSE-SU-2021:0600-1: An update that fixes three vulnerabilities is now available.

Category: security (moderate)
Bug References: 1182325,1182336,1182337
CVE References: CVE-2021-20243,CVE-2021-20244,CVE-2021-20246
JIRA References: 
Sources used:
SUSE Linux Enterprise Workstation Extension 12-SP5 (src):    ImageMagick-6.8.8.1-71.162.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    ImageMagick-6.8.8.1-71.162.1
SUSE Linux Enterprise Server 12-SP5 (src):    ImageMagick-6.8.8.1-71.162.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 11 Swamp Workflow Management 2021-02-25 17:21:55 UTC
SUSE-SU-2021:0605-1: An update that fixes four vulnerabilities is now available.

Category: security (moderate)
Bug References: 1182325,1182335,1182336,1182337
CVE References: CVE-2021-20241,CVE-2021-20243,CVE-2021-20244,CVE-2021-20246
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Development Tools 15-SP2 (src):    ImageMagick-7.0.7.34-10.12.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (src):    ImageMagick-7.0.7.34-10.12.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 12 Swamp Workflow Management 2021-03-03 14:18:53 UTC
openSUSE-SU-2021:0377-1: An update that fixes four vulnerabilities is now available.

Category: security (moderate)
Bug References: 1182325,1182335,1182336,1182337
CVE References: CVE-2021-20241,CVE-2021-20243,CVE-2021-20244,CVE-2021-20246
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    ImageMagick-7.0.7.34-lp152.12.12.1