Bug 1185047 - (CVE-2021-21224) VUL-0: chromium: Update to 90.0.4430.85
(CVE-2021-21224)
VUL-0: chromium: Update to 90.0.4430.85
Status: RESOLVED FIXED
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.2
Other Other
: P2 - High : Major (vote)
: ---
Assigned To: Security Team bot
E-mail List
https://smash.suse.de/issue/282419/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-04-21 07:10 UTC by Robert Frohl
Modified: 2021-12-15 09:50 UTC (History)
4 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2021-04-21 07:10:43 UTC
The Stable channel has been updated to 90.0.4430.85 for Windows, Mac and Linux which will roll out over the coming days/weeks.

A full list of changes in this build is available in the log. Interested in switching release channels?  Find out how here. If you find a new issue, please let us know by filing a bug. The community help forum is also a great place to reach out for help or learn about common issues.

Security Fixes and Rewards

Note: Access to bug details and links may be kept restricted until a majority of users are updated with a fix. We will also retain restrictions if the bug exists in a third party library that other projects similarly depend on, but haven’t yet fixed.

This update includes 7 security fixes. Below, we highlight fixes that were contributed by external researchers. Please see the Chrome Security Page for more information.


[$TBD][1194046] High CVE-2021-21222: Heap buffer overflow in V8. Reported by Guang Gong of Alpha Lab, Qihoo 360 on 2021-03-30

[$TBD][1195308] High CVE-2021-21223: Integer overflow in Mojo. Reported by Guang Gong of Alpha Lab, Qihoo 360 on 2021-04-02

[$TBD][1195777] High CVE-2021-21224: Type Confusion in V8. Reported by Jose Martinez (tr0y4) from VerSprite Inc. on 2021-04-05

[$TBD][1195977] High CVE-2021-21225: Out of bounds memory access in V8. Reported by Brendon Tiszka (@btiszka) supporting the EFF on 2021-04-05

[$TBD][1197904] High CVE-2021-21226: Use after free in navigation. Reported by Brendon Tiszka (@btiszka) supporting the EFF on 2021-04-11


We would also like to thank all security researchers that worked with us during the development cycle to prevent security bugs from ever reaching the stable channel.


Google is aware of reports that exploits for CVE-2021-21224 exist in the wild.

As usual, our ongoing internal security work was responsible for a wide range of fixes:

    [1200824] Various fixes from internal audits, fuzzing and other initiatives


Many of our security bugs are detected using AddressSanitizer, MemorySanitizer, UndefinedBehaviorSanitizer, Control Flow Integrity, libFuzzer, or AFL.



Srinivas Sista
Google Chrome

https://chromereleases.googleblog.com/2021/04/stable-channel-update-for-desktop_20.html
Comment 1 Robert Frohl 2021-04-21 12:18:08 UTC
submitted a simple version bump to 90.0.4430.85 in as a test build in home:rfrohl:branches:network:chromium/chromium. 

Not sure how much work these major version changes usually are, but maybe there are some results that might help the proper submission.
Comment 2 Robert Frohl 2021-04-22 06:49:05 UTC
(In reply to Robert Frohl from comment #1)
> submitted a simple version bump to 90.0.4430.85 in as a test build in
> home:rfrohl:branches:network:chromium/chromium. 
> 
> Not sure how much work these major version changes usually are, but maybe
> there are some results that might help the proper submission.

does not look like this will be helpful
Comment 3 OBSbugzilla Bot 2021-04-27 15:00:03 UTC
This is an autogenerated message for OBS integration:
This bug (1185047) was mentioned in
https://build.opensuse.org/request/show/888827 Factory / chromium
https://build.opensuse.org/request/show/888828 Backports:SLE-15-SP3 / chromium
Comment 4 OBSbugzilla Bot 2021-04-28 08:40:04 UTC
This is an autogenerated message for OBS integration:
This bug (1185047) was mentioned in
https://build.opensuse.org/request/show/888957 15.2 / chromium
Comment 5 OBSbugzilla Bot 2021-04-28 17:00:05 UTC
This is an autogenerated message for OBS integration:
This bug (1185047) was mentioned in
https://build.opensuse.org/request/show/889077 Factory / chromium
https://build.opensuse.org/request/show/889078 Backports:SLE-15-SP3 / chromium
Comment 6 OBSbugzilla Bot 2021-04-28 18:00:07 UTC
This is an autogenerated message for OBS integration:
This bug (1185047) was mentioned in
https://build.opensuse.org/request/show/889098 15.2 / chromium
Comment 7 Andreas Stieger 2021-04-30 15:50:25 UTC
back to security team
Comment 8 Andreas Stieger 2021-05-01 09:38:23 UTC
done
Comment 9 OBSbugzilla Bot 2021-12-15 09:50:07 UTC
This is an autogenerated message for OBS integration:
This bug (1185047) was mentioned in
https://build.opensuse.org/request/show/940663 Backports:SLE-12-SP3 / chromium