Bug 1184379 - (CVE-2021-21342) VUL-0: CVE-2021-21342: xstream: server-side forgery
(CVE-2021-21342)
VUL-0: CVE-2021-21342: xstream: server-side forgery
Status: RESOLVED FIXED
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Critical
: ---
Assigned To: Fridrich Strba
Security Team bot
https://smash.suse.de/issue/280246/
CVSSv3.1:SUSE:CVE-2021-21342:7.4:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-04-06 12:35 UTC by Robert Frohl
Modified: 2022-04-07 09:48 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2021-04-06 12:35:44 UTC
CVE-2021-21342

XStream is a Java library to serialize objects to XML and back again. In XStream
before version 1.4.16, there is a vulnerability where the processed stream at
unmarshalling time contains type information to recreate the formerly written
objects. XStream creates therefore new instances based on these type
information. An attacker can manipulate the processed input stream and replace
or inject objects, that result in a server-side forgery request. No user is
affected, who followed the recommendation to setup XStream's security framework
with a whitelist limited to the minimal required types. If you rely on XStream's
default blacklist of the Security Framework, you will have to use at least
version 1.4.16.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-21342
https://access.redhat.com/security/cve/CVE-2021-21342
https://github.com/x-stream/xstream/security/advisories/GHSA-hvv8-336g-rx3m
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-21342
https://x-stream.github.io/security.html#workaround
https://x-stream.github.io/CVE-2021-21342.html
http://x-stream.github.io/changes.html#1.4.16
https://lists.debian.org/debian-lts-announce/2021/04/msg00002.html
Comment 1 Robert Frohl 2021-04-06 12:39:42 UTC
tracking as affected:

- SUSE:SLE-15-SP1:Update:Products:Manager40:Update/xstream
- SUSE:SLE-15-SP2:Update/xstream
Comment 4 Swamp Workflow Management 2021-06-02 19:16:26 UTC
SUSE-SU-2021:1840-1: An update that fixes 11 vulnerabilities is now available.

Category: security (important)
Bug References: 1184372,1184373,1184374,1184375,1184376,1184377,1184378,1184379,1184380,1184796,1184797
CVE References: CVE-2021-21341,CVE-2021-21342,CVE-2021-21343,CVE-2021-21344,CVE-2021-21345,CVE-2021-21346,CVE-2021-21347,CVE-2021-21348,CVE-2021-21349,CVE-2021-21350,CVE-2021-21351
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for SUSE Manager Server 4.1 (src):    xstream-1.4.16-3.8.1
SUSE Linux Enterprise Module for Development Tools 15-SP3 (src):    xstream-1.4.16-3.8.1
SUSE Linux Enterprise Module for Development Tools 15-SP2 (src):    xstream-1.4.16-3.8.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2021-06-03 22:19:26 UTC
openSUSE-SU-2021:0832-1: An update that fixes 11 vulnerabilities is now available.

Category: security (important)
Bug References: 1184372,1184373,1184374,1184375,1184376,1184377,1184378,1184379,1184380,1184796,1184797
CVE References: CVE-2021-21341,CVE-2021-21342,CVE-2021-21343,CVE-2021-21344,CVE-2021-21345,CVE-2021-21346,CVE-2021-21347,CVE-2021-21348,CVE-2021-21349,CVE-2021-21350,CVE-2021-21351
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    xstream-1.4.16-lp152.2.6.1
Comment 8 Swamp Workflow Management 2021-07-11 13:57:34 UTC
openSUSE-SU-2021:1840-1: An update that fixes 11 vulnerabilities is now available.

Category: security (important)
Bug References: 1184372,1184373,1184374,1184375,1184376,1184377,1184378,1184379,1184380,1184796,1184797
CVE References: CVE-2021-21341,CVE-2021-21342,CVE-2021-21343,CVE-2021-21344,CVE-2021-21345,CVE-2021-21346,CVE-2021-21347,CVE-2021-21348,CVE-2021-21349,CVE-2021-21350,CVE-2021-21351
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    xstream-1.4.16-3.8.1
Comment 9 Swamp Workflow Management 2021-07-11 14:00:41 UTC
SUSE-SU-2021:1840-2: An update that fixes 11 vulnerabilities is now available.

Category: security (important)
Bug References: 1184372,1184373,1184374,1184375,1184376,1184377,1184378,1184379,1184380,1184796,1184797
CVE References: CVE-2021-21341,CVE-2021-21342,CVE-2021-21343,CVE-2021-21344,CVE-2021-21345,CVE-2021-21346,CVE-2021-21347,CVE-2021-21348,CVE-2021-21349,CVE-2021-21350,CVE-2021-21351
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for SUSE Manager Server 4.2 (src):    xstream-1.4.16-3.8.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 10 Fridrich Strba 2022-04-07 09:48:57 UTC
fixed