Bug 1184644 - (CVE-2021-28965) VUL-0: CVE-2021-28965: ruby2.5,ruby2.1,ruby: XML round-trip vulnerability in REXML
(CVE-2021-28965)
VUL-0: CVE-2021-28965: ruby2.5,ruby2.1,ruby: XML round-trip vulnerability in ...
Status: RESOLVED WONTFIX
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Marcus Rückert
Security Team bot
https://smash.suse.de/issue/281602/
CVSSv3.1:SUSE:CVE-2021-28965:5.3:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-04-13 06:52 UTC by Robert Frohl
Modified: 2022-09-29 08:01 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2021-04-13 06:52:34 UTC
rh#1947526

When parsing and serializing a crafted XML document, REXML gem (including the one bundled with Ruby) can create a wrong XML document whose structure is different from the original one. The impact of this issue highly depends on context, but it may lead to a vulnerability in some programs that are using REXML.

Reference:
https://www.ruby-lang.org/en/news/2021/04/05/xml-round-trip-vulnerability-in-rexml-cve-2021-28965/

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1947526
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-28965
https://access.redhat.com/security/cve/CVE-2021-28965
Comment 2 OBSbugzilla Bot 2021-04-13 13:30:04 UTC
This is an autogenerated message for OBS integration:
This bug (1184644) was mentioned in
https://build.opensuse.org/request/show/884952 Factory / ruby3.0
https://build.opensuse.org/request/show/884953 Factory / ruby2.7
Comment 3 Swamp Workflow Management 2021-04-20 16:34:04 UTC
SUSE-SU-2021:1280-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1184644
CVE References: CVE-2021-28965
JIRA References: 
Sources used:
SUSE MicroOS 5.0 (src):    ruby2.5-2.5.9-4.17.1
SUSE Linux Enterprise Module for Basesystem 15-SP2 (src):    ruby2.5-2.5.9-4.17.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 4 Swamp Workflow Management 2021-04-24 16:15:28 UTC
openSUSE-SU-2021:0607-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1184644
CVE References: CVE-2021-28965
JIRA References: 
Sources used:
openSUSE Leap 15.2 (src):    ruby2.5-2.5.9-lp152.2.6.1
Comment 8 Stoyan Manolov 2022-09-29 08:01:05 UTC
After careful consideration on our end, we have come to the decision that backporting this fix is not economically or timely feasible. Please reach out to security@suse.de in case of any questions.