Bug 1191306 - (CVE-2021-32626) VUL-0: CVE-2021-32626: redis: Specially crafted Lua scripts may result with Heap buffer overflow
(CVE-2021-32626)
VUL-0: CVE-2021-32626: redis: Specially crafted Lua scripts may result with H...
Status: IN_PROGRESS
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.3
Other Other
: P3 - Medium : Normal (vote)
: ---
Assigned To: Security Team bot
Security Team bot
CVSSv3.1:SUSE:CVE-2021-32626:7.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-10-04 20:58 UTC by Andreas Stieger
Modified: 2022-05-03 15:15 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Stieger 2021-10-04 20:58:35 UTC
Fixed in Redis 6.2.6, 6.0.16 and 5.0.14

CVE-2021-32626: Specially crafted Lua scripts may result with Heap buffer overflow

References:
https://github.com/redis/redis/commit/8f241ab3b8095186d008dbf78f0af90918f129bc
https://groups.google.com/g/redis-db/c/GS_9L2KCk9g/m/Q7ZN1R1cDAAJ
Comment 1 Michael Ströder 2021-10-04 21:18:59 UTC
Update for Tumbleweed:
https://build.opensuse.org/request/show/923120
Comment 2 Danilo Spinella 2021-10-06 08:26:51 UTC
Fix for branch 6.0:

https://github.com/redis/redis/commit/666ed7facf4524bf6d19b11b20faa2cf93fdf591
Comment 5 Swamp Workflow Management 2021-11-23 20:18:45 UTC
SUSE-SU-2021:3772-1: An update that fixes 8 vulnerabilities is now available.

Category: security (important)
Bug References: 1191299,1191300,1191302,1191303,1191304,1191305,1191306
CVE References: CVE-2021-32626,CVE-2021-32627,CVE-2021-32628,CVE-2021-32672,CVE-2021-32675,CVE-2021-32687,CVE-2021-32762,CVE-2021-41099
JIRA References: 
Sources used:
SUSE Linux Enterprise Module for Server Applications 15-SP3 (src):    redis-6.0.14-6.8.1
SUSE Linux Enterprise Module for Server Applications 15-SP2 (src):    redis-6.0.14-6.8.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2021-11-23 20:34:44 UTC
openSUSE-SU-2021:3772-1: An update that fixes 8 vulnerabilities is now available.

Category: security (important)
Bug References: 1191299,1191300,1191302,1191303,1191304,1191305,1191306
CVE References: CVE-2021-32626,CVE-2021-32627,CVE-2021-32628,CVE-2021-32672,CVE-2021-32675,CVE-2021-32687,CVE-2021-32762,CVE-2021-41099
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    redis-6.0.14-6.8.1