Bug 1189337 - (CVE-2021-32815) VUL-1: CVE-2021-32815: exiv2: exiv2: DoS due to assertion failure in crwimage_int.cpp
(CVE-2021-32815)
VUL-1: CVE-2021-32815: exiv2: exiv2: DoS due to assertion failure in crwimage...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Dirk Mueller
Security Team bot
https://smash.suse.de/issue/306106/
CVSSv3.1:SUSE:CVE-2021-32815:3.1:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-08-11 15:34 UTC by Gabriele Sonnu
Modified: 2021-08-12 07:55 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele Sonnu 2021-08-11 15:34:56 UTC
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. The assertion failure is triggered when Exiv2 is used to modify the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when modifying the metadata, which is a less frequently used Exiv2 operation than reading the metadata. For example, to trigger the bug in the Exiv2 command-line application, you need to add an extra command-line argument such as `fi`. ### Patches The bug is fixed in version v0.27.5. ### References Regression test and bug fix: #1739 ### For more information Please see our [security policy](https://github.com/Exiv2/exiv2/security/policy) for information about Exiv2 security.

Reference:
https://github.com/Exiv2/exiv2/security/advisories/GHSA-mv9g-fxh2-m49m

Upstream patch:
https://github.com/Exiv2/exiv2/pull/1739

References:
https://bugzilla.redhat.com/show_bug.cgi?id=1992198
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-32815
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-32815
https://github.com/Exiv2/exiv2/security/advisories/GHSA-mv9g-fxh2-m49m
https://github.com/Exiv2/exiv2/pull/1739
Comment 1 Gabriele Sonnu 2021-08-11 15:35:07 UTC
Affected Packages:

- SUSE:SLE-11:Update/exiv2  0.17.1
- SUSE:SLE-12:Update/exiv2  0.23
- SUSE:SLE-15:Update/exiv2  0.26
- openSUSE:Factory/exiv2    0.27.4