Bug 1194136 - (CVE-2021-45482) VUL-0: CVE-2021-45482: webkit2gtk3: use-after-free in WebCore:ContainerNode:firstChild
(CVE-2021-45482)
VUL-0: CVE-2021-45482: webkit2gtk3: use-after-free in WebCore:ContainerNode:f...
Status: RESOLVED INVALID
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P5 - None : Minor
: ---
Assigned To: E-mail List
Security Team bot
https://smash.suse.de/issue/318838/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2021-12-29 09:40 UTC by Thomas Leroy
Modified: 2021-12-29 09:40 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Leroy 2021-12-29 09:40:41 UTC
CVE-2021-45482

In WebKitGTK before 2.32.4, there is a use-after-free in
WebCore::ContainerNode::firstChild, a different vulnerability than
CVE-2021-30889.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2021-45482
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-45482
https://github.com/ChijinZ/security_advisories/tree/master/webkitgtk-2.32.3
http://www.cvedetails.com/cve/CVE-2021-45482/
Comment 1 Thomas Leroy 2021-12-29 09:40:55 UTC
Only versions prior 2.32.4 are affected. We ship at least 2.34.1, therefore this issue is already fixed.