Bug 1194539 - (CVE-2022-22844) VUL-1: CVE-2022-22844: tiff: out-of-bounds read in _TIFFmemcpy in tif_unix.c
(CVE-2022-22844)
VUL-1: CVE-2022-22844: tiff: out-of-bounds read in _TIFFmemcpy in tif_unix.c
Status: IN_PROGRESS
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P4 - Low : Minor
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/319802/
CVSSv3.1:SUSE:CVE-2022-22844:5.3:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-01-11 13:00 UTC by Thomas Leroy
Modified: 2022-02-18 14:35 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Leroy 2022-01-11 13:00:12 UTC
CVE-2022-22844

LibTIFF 4.3.0 has an out-of-bounds read in _TIFFmemcpy in tif_unix.c in certain
situations involving a custom tag and 0x0200 as the second word of the DE field.

Upstream PR (not merged yet):
https://gitlab.com/libtiff/libtiff/-/merge_requests/287


References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-22844
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-22844
https://gitlab.com/libtiff/libtiff/-/issues/355
https://gitlab.com/libtiff/libtiff/-/merge_requests/287
Comment 1 Thomas Leroy 2022-01-11 13:46:28 UTC
With ASan, I managed to trigger to overflow on the following codestreams:
- SUSE:SLE-11:Update	       3.8.2-141.169.31.1	
- SUSE:SLE-12:Update 	       4.0.9-44.24.1	
- SUSE:SLE-15:Update 	       4.0.9
- openSUSE:Factory             4.3.0
- openSUSE:Leap:15.3:Update    4.0.9
- openSUSE:Leap:15.4:Update    4.0.9
Comment 2 Thomas Leroy 2022-01-13 09:05:37 UTC
(In reply to Thomas Leroy from comment #1)
> With ASan, I managed to trigger to overflow on the following codestreams:
> - SUSE:SLE-11:Update	       3.8.2-141.169.31.1	

My mistake, SUSE:SLE-11:Update doesn't trigger the crash, and therefore is not affected.
Comment 4 Michael Vetter 2022-02-02 12:24:11 UTC
submitted
Comment 5 Swamp Workflow Management 2022-02-17 17:19:20 UTC
openSUSE-SU-2022:0480-1: An update that fixes 8 vulnerabilities is now available.

Category: security (important)
Bug References: 1071031,1154365,1182808,1182809,1182811,1182812,1190312,1194539
CVE References: CVE-2017-17095,CVE-2019-17546,CVE-2020-19131,CVE-2020-35521,CVE-2020-35522,CVE-2020-35523,CVE-2020-35524,CVE-2022-22844
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    tiff-4.0.9-45.5.1
openSUSE Leap 15.3 (src):    tiff-4.0.9-45.5.1
Comment 6 Swamp Workflow Management 2022-02-17 17:23:05 UTC
SUSE-SU-2022:0480-1: An update that fixes 8 vulnerabilities is now available.

Category: security (important)
Bug References: 1071031,1154365,1182808,1182809,1182811,1182812,1190312,1194539
CVE References: CVE-2017-17095,CVE-2019-17546,CVE-2020-19131,CVE-2020-35521,CVE-2020-35522,CVE-2020-35523,CVE-2020-35524,CVE-2022-22844
JIRA References: 
Sources used:
SUSE Manager Server 4.1 (src):    tiff-4.0.9-45.5.1
SUSE Manager Retail Branch Server 4.1 (src):    tiff-4.0.9-45.5.1
SUSE Manager Proxy 4.1 (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Server for SAP 15 (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Server 15-LTSS (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Realtime Extension 15-SP2 (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP4 (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    tiff-4.0.9-45.5.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    tiff-4.0.9-45.5.1
SUSE Enterprise Storage 7 (src):    tiff-4.0.9-45.5.1
SUSE Enterprise Storage 6 (src):    tiff-4.0.9-45.5.1
SUSE CaaS Platform 4.0 (src):    tiff-4.0.9-45.5.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2022-02-18 14:35:11 UTC
SUSE-SU-2022:0496-1: An update that fixes 8 vulnerabilities is now available.

Category: security (important)
Bug References: 1071031,1154365,1182808,1182809,1182811,1182812,1190312,1194539
CVE References: CVE-2017-17095,CVE-2019-17546,CVE-2020-19131,CVE-2020-35521,CVE-2020-35522,CVE-2020-35523,CVE-2020-35524,CVE-2022-22844
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    tiff-4.0.9-44.45.1
SUSE OpenStack Cloud Crowbar 8 (src):    tiff-4.0.9-44.45.1
SUSE OpenStack Cloud 9 (src):    tiff-4.0.9-44.45.1
SUSE OpenStack Cloud 8 (src):    tiff-4.0.9-44.45.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    tiff-4.0.9-44.45.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    tiff-4.0.9-44.45.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    tiff-4.0.9-44.45.1
SUSE Linux Enterprise Server 12-SP5 (src):    tiff-4.0.9-44.45.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    tiff-4.0.9-44.45.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    tiff-4.0.9-44.45.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    tiff-4.0.9-44.45.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    tiff-4.0.9-44.45.1
HPE Helion Openstack 8 (src):    tiff-4.0.9-44.45.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.