Bug 1198086 - (CVE-2022-24801) VUL-0: CVE-2022-24801: python-Twisted: Twisted Web HTTP 1.1 server parsed several HTTP request constructs more leniently than permitted by RFC 7230
(CVE-2022-24801)
VUL-0: CVE-2022-24801: python-Twisted: Twisted Web HTTP 1.1 server parsed sev...
Status: IN_PROGRESS
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/328061/
CVSSv3.1:SUSE:CVE-2022-24801:6.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-04-05 11:32 UTC by Hu
Modified: 2022-05-28 21:44 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hu 2022-04-05 11:32:17 UTC
CVE-2022-24801

Twisted is an event-based framework for internet applications, supporting Python
3.6+. Prior to version 22.4.0rc1, the Twisted Web HTTP 1.1 server, located in
the `twisted.web.http` module, parsed several HTTP request constructs more
leniently than permitted by RFC 7230. This non-conformant parsing can lead to
desync if requests pass through multiple HTTP parsers, potentially resulting in
HTTP request smuggling. Users who may be affected use Twisted Web's HTTP 1.1
server and/or proxy and also pass requests through a different HTTP server
and/or proxy. The Twisted Web client is not affected. The HTTP 2.0 server uses a
different parser, so it is not affected. The issue has been addressed in Twisted
22.4.0rc1. Two workarounds are available: Ensure any vulnerabilities in upstream
proxies have been addressed, such as by upgrading them; or filter malformed
requests by other means, such as configuration of an upstream proxy.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-24801
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24801
https://github.com/twisted/twisted/commit/592217e951363d60e9cd99c5bbfd23d4615043ac
https://github.com/twisted/twisted/releases/tag/twisted-22.4.0rc1
https://github.com/twisted/twisted/security/advisories/GHSA-c2jg-hw38-jrqq
Comment 1 Hu 2022-04-05 11:34:03 UTC
Affects:
- SUSE:SLE-12:Update/python-Twisted     15.2.1      
- SUSE:SLE-15-SP2:Update/python-Twisted 19.10.0     
- SUSE:SLE-15-SP4:Update/python-Twisted 21.7.0      
- openSUSE:Factory/python-Twisted       22.1.0
Comment 2 OBSbugzilla Bot 2022-04-06 07:40:03 UTC
This is an autogenerated message for OBS integration:
This bug (1198086) was mentioned in
https://build.opensuse.org/request/show/967193 Factory / python-Twisted
Comment 3 OBSbugzilla Bot 2022-04-07 03:10:03 UTC
This is an autogenerated message for OBS integration:
This bug (1198086) was mentioned in
https://build.opensuse.org/request/show/967387 Factory / python-Twisted
Comment 7 Swamp Workflow Management 2022-04-29 19:24:23 UTC
SUSE-SU-2022:1477-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1198086
CVE References: CVE-2022-24801
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    python-Twisted-19.10.0-150200.3.9.1
openSUSE Leap 15.3 (src):    python-Twisted-19.10.0-150200.3.9.1
SUSE Linux Enterprise Realtime Extension 15-SP2 (src):    python-Twisted-19.10.0-150200.3.9.1
SUSE Linux Enterprise Module for Server Applications 15-SP3 (src):    python-Twisted-19.10.0-150200.3.9.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    python-Twisted-19.10.0-150200.3.9.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2022-05-05 19:16:11 UTC
SUSE-SU-2022:1546-1: An update that fixes one vulnerability is now available.

Category: security (moderate)
Bug References: 1198086
CVE References: CVE-2022-24801
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    python-Twisted-15.2.1-9.14.1
SUSE OpenStack Cloud Crowbar 8 (src):    python-Twisted-15.2.1-9.14.1
SUSE OpenStack Cloud 9 (src):    python-Twisted-15.2.1-9.14.1
SUSE OpenStack Cloud 8 (src):    python-Twisted-15.2.1-9.14.1
SUSE Linux Enterprise Module for Web Scripting 12 (src):    python-Twisted-15.2.1-9.14.1
HPE Helion Openstack 8 (src):    python-Twisted-15.2.1-9.14.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.