Bug 1202435 - (CVE-2022-24949) VUL-0: CVE-2022-24949: EternalTerminal: privilege escalation to root
(CVE-2022-24949)
VUL-0: CVE-2022-24949: EternalTerminal: privilege escalation to root
Status: IN_PROGRESS
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.5
Other Other
: P3 - Medium : Minor (vote)
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/339931/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-08-16 12:22 UTC by Robert Frohl
Modified: 2022-11-02 17:29 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2022-08-16 12:22:09 UTC
CVE-2022-24949

A privilege escalation to root exists in Eternal Terminal prior to version
6.2.0. This is due to the combination of a race condition, buffer overflow, and
logic bug all in PipeSocketHandler::listen().

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-24949
https://github.com/metaredteam/external-disclosures/security/advisories/GHSA-hxg8-4r3q-p9rv
https://github.com/MisterTea/EternalTerminal/commit/900348bb8bc96e1c7ba4888ac8480f643c43d3c3
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-24949
Comment 1 Robert Frohl 2022-08-16 12:22:34 UTC
already fixed in openSUSE:Factory but open for openSUSE:Backports:SLE-15-SP*
Comment 2 Michael Vetter 2022-08-18 06:31:11 UTC
I think a version upgrade would make sense here.

SR#SR#997668 to Factory to include CVE/bugnumbers and adding the switch to choose gcc for Leap versions

Update to 6.2.1:
openSUSE_Backports_SLE-15-SP3_Update SR#997669                              
openSUSE_Backports_SLE-15-SP4_Update SR#997670

Where do I need to submit Leap 15.5 to?
Comment 3 OBSbugzilla Bot 2022-08-18 08:40:19 UTC
This is an autogenerated message for OBS integration:
This bug (1202435) was mentioned in
https://build.opensuse.org/request/show/997668 Factory / EternalTerminal
https://build.opensuse.org/request/show/997669 Backports:SLE-15-SP3 / EternalTerminal
https://build.opensuse.org/request/show/997670 Backports:SLE-15-SP4 / EternalTerminal
Comment 4 Robert Frohl 2022-08-24 14:56:47 UTC
(In reply to Michael Vetter from comment #2)
> Where do I need to submit Leap 15.5 to?

good question, simply submitting to openSUSE:Backports:SLE-15-SP5/EternalTerminal does not work ?
Comment 5 Swamp Workflow Management 2022-11-02 17:24:32 UTC
openSUSE-SU-2022:10187-1: An update that fixes four vulnerabilities is now available.

Category: security (important)
Bug References: 1202432,1202433,1202434,1202435
CVE References: CVE-2022-24949,CVE-2022-24950,CVE-2022-24951,CVE-2022-24952
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP3 (src):    EternalTerminal-6.2.1-bp153.2.3.1
Comment 6 Swamp Workflow Management 2022-11-02 17:29:03 UTC
openSUSE-SU-2022:10185-1: An update that fixes four vulnerabilities is now available.

Category: security (important)
Bug References: 1202432,1202433,1202434,1202435
CVE References: CVE-2022-24949,CVE-2022-24950,CVE-2022-24951,CVE-2022-24952
JIRA References: 
Sources used:
openSUSE Backports SLE-15-SP4 (src):    EternalTerminal-6.2.1-bp154.2.3.1