Bug 1199474 - (CVE-2022-26691) VUL-0: CVE-2022-26691: cups: authentication bypass and code execution
(CVE-2022-26691)
VUL-0: CVE-2022-26691: cups: authentication bypass and code execution
Status: IN_PROGRESS
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P2 - High : Major
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/331568/
CVSSv3.1:SUSE:CVE-2022-26691:8.1:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-05-12 08:56 UTC by Robert Frohl
Modified: 2022-06-03 12:45 UTC (History)
3 users (show)

See Also:
Found By: ---
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 24 Gianluca Gabrielli 2022-05-26 08:00:26 UTC
This is now public:

Impact: An application may be able to gain elevated privileges
Description: A logic issue was addressed with improved state management.

References:
https://support.apple.com/en-us/HT213183
https://github.com/OpenPrinting/cups/releases/tag/v2.4.2
Comment 25 Swamp Workflow Management 2022-05-26 13:18:58 UTC
SUSE-SU-2022:1861-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1199474
CVE References: CVE-2022-26691
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    cups-2.2.7-150000.3.32.1
openSUSE Leap 15.3 (src):    cups-2.2.7-150000.3.32.1
SUSE Manager Server 4.1 (src):    cups-2.2.7-150000.3.32.1
SUSE Manager Retail Branch Server 4.1 (src):    cups-2.2.7-150000.3.32.1
SUSE Manager Proxy 4.1 (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Server for SAP 15 (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Server 15-LTSS (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Module for Development Tools 15-SP4 (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Module for Development Tools 15-SP3 (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise Micro 5.2 (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    cups-2.2.7-150000.3.32.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    cups-2.2.7-150000.3.32.1
SUSE Enterprise Storage 7 (src):    cups-2.2.7-150000.3.32.1
SUSE Enterprise Storage 6 (src):    cups-2.2.7-150000.3.32.1
SUSE CaaS Platform 4.0 (src):    cups-2.2.7-150000.3.32.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 26 Johannes Meixner 2022-05-30 09:10:04 UTC
CUPS 2.4.2 is now in OBS Printing, see
https://build.opensuse.org/request/show/979802
Comment 27 Johannes Meixner 2022-06-02 08:10:50 UTC
CUPS 2.4.2 submitted to openSUSE:Factory
--------------------------------------------------------------
# osc submitrequest -m 'CUPS version upgrade to 2.4.2 \
 which includes a fix for CVE-2022-26691 (#bsc1199474)' \
 Printing cups openSUSE:Factory cups
...
created request id 980461
--------------------------------------------------------------
Comment 28 Johannes Meixner 2022-06-03 12:43:51 UTC
https://build.opensuse.org/request/show/980461
is accepted so all affected products are fixed