Bug 1199240 - (CVE-2022-29155) VUL-0: CVE-2022-29155: openldap2: SQL injection in the back-sql backend to slapd
(CVE-2022-29155)
VUL-0: CVE-2022-29155: openldap2: SQL injection in the back-sql backend to slapd
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Critical
: ---
Assigned To: William Brown
Security Team bot
https://smash.suse.de/issue/330744/
CVSSv3.1:SUSE:CVE-2022-29155:9.4:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-05-05 11:57 UTC by Hu
Modified: 2022-05-24 13:22 UTC (History)
3 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hu 2022-05-05 11:57:53 UTC
rh#2081935

In OpenLDAP 2.x before 2.5.12 and 2.6.x before 2.6.2, a SQL injection vulnerability exists in the experimental back-sql backend to slapd, via a SQL statement within an LDAP query. This can occur during an LDAP search operation when the search filter is processed, due to a lack of proper escaping.

https://bugs.openldap.org/show_bug.cgi?id=9815

References:
https://bugzilla.redhat.com/show_bug.cgi?id=2081935
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-29155
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-29155
https://bugs.openldap.org/show_bug.cgi?id=9815
Comment 1 Hu 2022-05-05 11:58:08 UTC
Affected:
 - SUSE:SLE-11-SP3:Update/openldap2   2.4.26
 - SUSE:SLE-12-SP2:Update/openldap2   2.4.41
 - SUSE:SLE-12-SP4:Update/openldap2   2.4.41
 - SUSE:SLE-12:Update/openldap2       2.4.41
 - SUSE:SLE-15-SP2:Update/openldap2   2.4.46
 - SUSE:SLE-15:Update/openldap2       2.4.46
 - openSUSE:Factory/openldap2         2.6.1
Comment 4 Swamp Workflow Management 2022-05-16 13:33:51 UTC
SUSE-SU-2022:1671-1: An update that solves one vulnerability and has one errata is now available.

Category: security (important)
Bug References: 1198383,1199240
CVE References: CVE-2022-29155
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 8 (src):    openldap2-2.4.41-18.89.1
SUSE OpenStack Cloud 8 (src):    openldap2-2.4.41-18.89.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    openldap2-2.4.41-18.89.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    openldap2-2.4.41-18.89.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    openldap2-2.4.41-18.89.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    openldap2-2.4.41-18.89.1
HPE Helion Openstack 8 (src):    openldap2-2.4.41-18.89.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2022-05-16 13:42:45 UTC
SUSE-SU-2022:1670-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1199240
CVE References: CVE-2022-29155
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    openldap2-2.4.46-150200.14.8.1
openSUSE Leap 15.3 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Manager Server 4.1 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Manager Retail Branch Server 4.1 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Manager Proxy 4.1 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise Module for Legacy Software 15-SP3 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise Module for Development Tools 15-SP4 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise Module for Development Tools 15-SP3 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise Micro 5.2 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise Micro 5.1 (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    openldap2-2.4.46-150200.14.8.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    openldap2-2.4.46-150200.14.8.1
SUSE Enterprise Storage 7 (src):    openldap2-2.4.46-150200.14.8.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2022-05-16 16:20:34 UTC
SUSE-SU-2022:1685-1: An update that fixes one vulnerability is now available.

Category: security (important)
Bug References: 1199240
CVE References: CVE-2022-29155
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 12-SP5 (src):    openldap2-2.4.41-42.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    openldap2-2.4.41-42.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    openldap2-2.4.41-42.1
SUSE Linux Enterprise Module for Legacy Software 12 (src):    openldap2-2.4.41-42.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Robin Knapp 2022-05-17 08:00:08 UTC
Does SUSE deliver back-sql?
According to the source package, it should be in back-sql subpackage, but this does not seem to exist in SLES.
Customers are starting to discuss this issue and a statement from SUSE would be helpful.
Comment 8 Hu 2022-05-17 12:55:25 UTC
Hi Robin,

the back-sql subpackage of openldap2 is only installable from certain openSUSE repositories. The subpackage is not included in the official SLES repositories.

Please refer to the official CVE page from SUSE for official statements and customer information about this CVE:
https://www.suse.com/de-de/security/cve/CVE-2022-29155.html

If you need more help, please reach out again!
Comment 9 Robin Knapp 2022-05-17 14:50:32 UTC
Yes this is what I found out so far, thank you for confirmation.

In the linked information, there are lots of references to SLES, so customers may assume that SLES is affected - even the patches are listed.
I do not see any statement that SLES does not include affected components.
Comment 10 Marcus Meissner 2022-05-18 08:00:28 UTC
I added a note to our CVE page (will appear around 1200 CEST)

The vulnerability is in the openldap2-back-sql sub-package, not in the main package. The back-sql package is only delivered to openSUSE Leap, not to SUSE Linux Enterprise.
Comment 11 Robin Knapp 2022-05-18 09:10:06 UTC
Great, thank you
Comment 12 Swamp Workflow Management 2022-05-20 16:16:12 UTC
SUSE-SU-2022:1771-1: An update that solves one vulnerability and has one errata is now available.

Category: security (important)
Bug References: 1198383,1199240
CVE References: CVE-2022-29155
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    openldap2-2.4.41-22.10.1
SUSE OpenStack Cloud 9 (src):    openldap2-2.4.41-22.10.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    openldap2-2.4.41-22.10.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    openldap2-2.4.41-22.10.1
SUSE Linux Enterprise Server 12-SP5 (src):    openldap2-2.4.41-22.10.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    openldap2-2.4.41-22.10.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 13 Swamp Workflow Management 2022-05-24 13:22:45 UTC
SUSE-SU-2022:1832-1: An update that solves one vulnerability, contains one feature and has two fixes is now available.

Category: security (important)
Bug References: 1191157,1197004,1199240
CVE References: CVE-2022-29155
JIRA References: PM-3288
Sources used:
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    openldap2-2.4.46-150000.9.71.1
SUSE Linux Enterprise Server for SAP 15 (src):    openldap2-2.4.46-150000.9.71.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    openldap2-2.4.46-150000.9.71.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    openldap2-2.4.46-150000.9.71.1
SUSE Linux Enterprise Server 15-LTSS (src):    openldap2-2.4.46-150000.9.71.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    openldap2-2.4.46-150000.9.71.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    openldap2-2.4.46-150000.9.71.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    openldap2-2.4.46-150000.9.71.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    openldap2-2.4.46-150000.9.71.1
SUSE Enterprise Storage 6 (src):    openldap2-2.4.46-150000.9.71.1
SUSE CaaS Platform 4.0 (src):    openldap2-2.4.46-150000.9.71.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.