Bug 1199287 - (CVE-2022-30293) VUL-0: CVE-2022-30293: webkitgtk,webkitgtk3,webkit2gtk3,libQtWebKit4,libqt5-qtwebkit: heap-buffer-overflow in WebCore:TextureMapperLayer:setContentsLayer
(CVE-2022-30293)
VUL-0: CVE-2022-30293: webkitgtk,webkitgtk3,webkit2gtk3,libQtWebKit4,libqt5-q...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/330980/
CVSSv3.1:SUSE:CVE-2022-30293:6.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-05-06 15:15 UTC by Hu
Modified: 2022-06-15 13:15 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Hu 2022-05-06 15:19:47 UTC
Affected:
 - SUSE:SLE-12-SP2:Update/webkit2gtk3                    2.34.6
 - SUSE:SLE-15-SP2:Update/webkit2gtk3                    2.36.0
 - SUSE:SLE-15-SP4:Update/webkit2gtk3                    2.36.0
 - SUSE:SLE-15:Update/webkit2gtk3                        2.36.0

Not Affected:
 - SUSE:SLE-12:Update/libQtWebKit4                  4.8.7+2.3.4
 - SUSE:SLE-12-SP2:Update/webkitgtk                      2.4.11
 - SUSE:SLE-12-SP2:Update/webkitgtk3                     2.4.11
 - SUSE:SLE-12-SP2:Update/libqt5-qtwebkit                 5.6.1
 - SUSE:SLE-12-SP3:Update/libqt5-qtwebkit                 5.6.2
 - openSUSE:Backports:SLE-15-SP3/libqt5-qtwebkit   5.212~alpha3
 - openSUSE:Backports:SLE-15-SP4/libqt5-qtwebkit   5.212~alpha4
 - openSUSE:Factory/webkit2gtk3                          2.36.1

Fixing patch should be the following I think: https://github.com/WebKit/WebKit/commit/fb8ed3d7e9868de82621015783d1f0cc1080b4e4
Comment 2 Michael Gorse 2022-06-01 15:04:56 UTC
I'm going to update webkitgtk to 2.36.3 (boo#1200106).
Comment 4 Swamp Workflow Management 2022-06-09 13:17:04 UTC
SUSE-SU-2022:2030-1: An update that fixes 6 vulnerabilities is now available.

Category: security (important)
Bug References: 1199287,1200106
CVE References: CVE-2022-26700,CVE-2022-26709,CVE-2022-26716,CVE-2022-26717,CVE-2022-26719,CVE-2022-30293
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    webkit2gtk3-2.36.3-150000.3.103.1
SUSE Linux Enterprise Server for SAP 15 (src):    webkit2gtk3-2.36.3-150000.3.103.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    webkit2gtk3-2.36.3-150000.3.103.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    webkit2gtk3-2.36.3-150000.3.103.1
SUSE Linux Enterprise Server 15-LTSS (src):    webkit2gtk3-2.36.3-150000.3.103.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    webkit2gtk3-2.36.3-150000.3.103.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    webkit2gtk3-2.36.3-150000.3.103.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    webkit2gtk3-2.36.3-150000.3.103.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    webkit2gtk3-2.36.3-150000.3.103.1
SUSE Enterprise Storage 6 (src):    webkit2gtk3-2.36.3-150000.3.103.1
SUSE CaaS Platform 4.0 (src):    webkit2gtk3-2.36.3-150000.3.103.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 5 Swamp Workflow Management 2022-06-14 13:21:59 UTC
SUSE-SU-2022:2071-1: An update that fixes 6 vulnerabilities is now available.

Category: security (important)
Bug References: 1199287,1200106
CVE References: CVE-2022-26700,CVE-2022-26709,CVE-2022-26716,CVE-2022-26717,CVE-2022-26719,CVE-2022-30293
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    webkit2gtk3-2.36.3-150400.4.3.1, webkit2gtk3-soup2-2.36.3-150400.4.3.1, webkit2gtk4-2.36.3-150400.4.3.1
SUSE Linux Enterprise Module for Development Tools 15-SP4 (src):    webkit2gtk4-2.36.3-150400.4.3.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (src):    webkit2gtk3-2.36.3-150400.4.3.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    webkit2gtk3-soup2-2.36.3-150400.4.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2022-06-14 13:23:00 UTC
SUSE-SU-2022:2072-1: An update that fixes 6 vulnerabilities is now available.

Category: security (important)
Bug References: 1199287,1200106
CVE References: CVE-2022-26700,CVE-2022-26709,CVE-2022-26716,CVE-2022-26717,CVE-2022-26719,CVE-2022-30293
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    webkit2gtk3-2.36.3-150200.35.1
openSUSE Leap 15.3 (src):    webkit2gtk3-2.36.3-150200.35.1
SUSE Manager Server 4.1 (src):    webkit2gtk3-2.36.3-150200.35.1
SUSE Manager Retail Branch Server 4.1 (src):    webkit2gtk3-2.36.3-150200.35.1
SUSE Manager Proxy 4.1 (src):    webkit2gtk3-2.36.3-150200.35.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    webkit2gtk3-2.36.3-150200.35.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    webkit2gtk3-2.36.3-150200.35.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    webkit2gtk3-2.36.3-150200.35.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    webkit2gtk3-2.36.3-150200.35.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    webkit2gtk3-2.36.3-150200.35.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    webkit2gtk3-2.36.3-150200.35.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    webkit2gtk3-2.36.3-150200.35.1
SUSE Enterprise Storage 7 (src):    webkit2gtk3-2.36.3-150200.35.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2022-06-15 13:15:34 UTC
SUSE-SU-2022:2089-1: An update that fixes 6 vulnerabilities is now available.

Category: security (important)
Bug References: 1199287,1200106
CVE References: CVE-2022-26700,CVE-2022-26709,CVE-2022-26716,CVE-2022-26717,CVE-2022-26719,CVE-2022-30293
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    webkit2gtk3-2.36.3-2.99.1
SUSE OpenStack Cloud Crowbar 8 (src):    webkit2gtk3-2.36.3-2.99.1
SUSE OpenStack Cloud 9 (src):    webkit2gtk3-2.36.3-2.99.1
SUSE OpenStack Cloud 8 (src):    webkit2gtk3-2.36.3-2.99.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    webkit2gtk3-2.36.3-2.99.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    webkit2gtk3-2.36.3-2.99.1
SUSE Linux Enterprise Server for SAP 12-SP3 (src):    webkit2gtk3-2.36.3-2.99.1
SUSE Linux Enterprise Server 12-SP5 (src):    webkit2gtk3-2.36.3-2.99.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    webkit2gtk3-2.36.3-2.99.1
SUSE Linux Enterprise Server 12-SP3-LTSS (src):    webkit2gtk3-2.36.3-2.99.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    webkit2gtk3-2.36.3-2.99.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    webkit2gtk3-2.36.3-2.99.1
HPE Helion Openstack 8 (src):    webkit2gtk3-2.36.3-2.99.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.