Bug 1203105 - (CVE-2022-31152) VUL-0: CVE-2022-31152: matrix-synapse: denial of service due to incorrect application of event authorization rules
(CVE-2022-31152)
VUL-0: CVE-2022-31152: matrix-synapse: denial of service due to incorrect app...
Status: NEW
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.4
Other Other
: P3 - Medium : Minor (vote)
: ---
Assigned To: Aleksa Sarai
Security Team bot
https://smash.suse.de/issue/341463/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-09-05 08:18 UTC by Thomas Leroy
Modified: 2022-09-05 09:15 UTC (History)
0 users

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Leroy 2022-09-05 08:18:56 UTC
rh#2124168

Synapse is an open-source Matrix homeserver written and maintained by the
Matrix.org Foundation. The Matrix specification specifies a list of [event
authorization rules](https://spec.matrix.org/v1.2/rooms/v9/#authorization-rules)
which must be checked when determining if an event should be accepted into a
room. In versions of Synapse up to and including version 1.61.0, some of these
rules are not correctly applied. An attacker could craft events which would be
accepted by Synapse but not a spec-conformant server, potentially causing
divergence in the room state between servers. Administrators of homeservers with
federation enabled are advised to upgrade to version 1.62.0 or higher.
Federation can be disabled by setting
[`federation_domain_whitelist`](https://matrix-org.github.io/synapse/latest/usage/configuration/config_documentation.html#federation_domain_whitelist)
to an empty list (`[]`) as a workaround.

References:
https://bugzilla.redhat.com/show_bug.cgi?id=2124168
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-31152
https://github.com/matrix-org/synapse/pull/13087
https://github.com/matrix-org/synapse/releases/tag/v1.62.0
https://github.com/matrix-org/synapse/security/advisories/GHSA-jhjh-776m-4765
https://github.com/matrix-org/synapse/pull/13088
https://www.cve.org/CVERecord?id=CVE-2022-31152
Comment 1 Thomas Leroy 2022-09-05 08:32:53 UTC
openSUSE:Factory already fixed. 
openSUSE:Backports:SLE-15-SP3 quite old version, don't know if it's affected.