Bug 1199951 - (CVE-2022-31621) VUL-0: CVE-2022-31621: mariadb,mariadb-100: MariaDB Server before 10.7 is vulnerable to Denial of Service. In extra/mariabackup/ds_xbstream.cc
(CVE-2022-31621)
VUL-0: CVE-2022-31621: mariadb,mariadb-100: MariaDB Server before 10.7 is vul...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/332955/
CVSSv3.1:SUSE:CVE-2022-31621:5.3:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-05-26 15:10 UTC by Gianluca Gabrielli
Modified: 2022-05-30 08:39 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gianluca Gabrielli 2022-05-26 15:10:26 UTC
MariaDB Server before 10.7 is vulnerable to Denial of Service. In
extra/mariabackup/ds_xbstream.cc, when an error occurs (stream_ctxt->dest_file
== NULL) while executing the method xbstream_open, the held lock is not released
correctly, which allows local users to trigger a denial of service due to the
deadlock.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-31621
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-31621
https://github.com/MariaDB/server/commit/b1351c15946349f9daa7e5297fb2ac6f3139e4a8
https://jira.mariadb.org/browse/MDEV-26574?filter=-2
Comment 1 Gianluca Gabrielli 2022-05-26 15:11:14 UTC
affected package:
 - SUSE:SLE-12-SP3:Update:Products:Cloud8:Update/mariadb

upstream path [0].

[0] https://github.com/MariaDB/server/commit/b1351c15946349f9daa7e5297fb2ac6f3139e4a8
Comment 3 Christian Almeida de Oliveira 2022-05-30 08:39:45 UTC
based on comment #2, back to Security team.