Bug 1199946 - (CVE-2022-31650) VUL-1: CVE-2022-31650: sox: floating point exception in aiff.c
(CVE-2022-31650)
VUL-1: CVE-2022-31650: sox: floating point exception in aiff.c
Status: NEW
Classification: openSUSE
Product: openSUSE Distribution
Classification: openSUSE
Component: Security
Leap 15.3
Other Other
: P4 - Low : Minor (vote)
: ---
Assigned To: Pavol Rusnak
Security Team bot
https://smash.suse.de/issue/332950/
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-05-26 13:13 UTC by Carlos López
Modified: 2022-05-26 13:15 UTC (History)
0 users

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos López 2022-05-26 13:13:09 UTC
CVE-2022-31650

In SoX 14.4.2, there is a floating-point exception in lsx_aiffstartwrite in
aiff.c in libsox.a.

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-31650
http://www.cvedetails.com/cve/CVE-2022-31650/
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-31650
https://sourceforge.net/p/sox/bugs/360/