Bug 1203388 - (CVE-2022-3190) VUL-0: CVE-2022-3190: wireshark: Infinite loop in the F5 Ethernet Trailer protocol dissector
(CVE-2022-3190)
VUL-0: CVE-2022-3190: wireshark: Infinite loop in the F5 Ethernet Trailer pro...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Robert Frohl
Security Team bot
https://smash.suse.de/issue/342203/
CVSSv3.1:SUSE:CVE-2022-3190:6.5:(AV:N...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-09-14 06:59 UTC by Robert Frohl
Modified: 2022-09-19 19:32 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Frohl 2022-09-14 06:59:24 UTC
CVE-2022-3190

Infinite loop in the F5 Ethernet Trailer protocol dissector in Wireshark 3.6.0
to 3.6.7 and 3.4.0 to 3.4.15 allows denial of service via packet injection or
crafted capture file

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-3190
https://www.cve.org/CVERecord?id=CVE-2022-3190
https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-3190.json
https://gitlab.com/wireshark/wireshark/-/issues/18307
https://www.wireshark.org/security/wnpa-sec-2022-06.html
Comment 1 Robert Frohl 2022-09-14 07:13:55 UTC
fixed in Factory, needed in SUSE:SLE-15:Update
Comment 4 Swamp Workflow Management 2022-09-19 19:32:19 UTC
SUSE-SU-2022:3309-1: An update that fixes two vulnerabilities is now available.

Category: security (moderate)
Bug References: 1194165,1203388
CVE References: CVE-2021-4186,CVE-2022-3190
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    wireshark-3.6.8-150000.3.74.1
openSUSE Leap 15.3 (src):    wireshark-3.6.8-150000.3.74.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP4 (src):    wireshark-3.6.8-150000.3.74.1
SUSE Linux Enterprise Module for Desktop Applications 15-SP3 (src):    wireshark-3.6.8-150000.3.74.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    wireshark-3.6.8-150000.3.74.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    wireshark-3.6.8-150000.3.74.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.