Bug 1202816 - (CVE-2022-38533) VUL-0: CVE-2022-38533: binutils: heap out-of-bounds read in bfd_getl32
(CVE-2022-38533)
VUL-0: CVE-2022-38533: binutils: heap out-of-bounds read in bfd_getl32
Status: IN_PROGRESS
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Michael Matz
Security Team bot
https://smash.suse.de/issue/340903/
CVSSv3.1:SUSE:CVE-2022-38533:5.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-08-26 12:43 UTC by Thomas Leroy
Modified: 2022-11-29 17:45 UTC (History)
2 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Leroy 2022-08-26 12:43:36 UTC
CVE-2022-38533

In GNU Binutils before 2.4.0, there is a heap-buffer-overflow in the error
function bfd_getl32 when called from the strip_main function in strip-new via a
crafted file.

Upstream fix:
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=ef186fe54aa6d281a3ff8a9528417e5cc614c797

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-38533
https://www.cve.org/CVERecord?id=CVE-2022-38533
https://sourceware.org/bugzilla/show_bug.cgi?id=29482
Comment 1 Thomas Leroy 2022-08-26 12:45:36 UTC
Every maintained codestream is affected:
- SUSE:SLE-11-SP1:Update:Teradata -> WONTFIX according to bsc#1126829	
- SUSE:SLE-12:Update
- SUSE:SLE-15:Update
- SUSE:SLE-15-SP1:Update

Michael, could you please include the fix for this bug in the next update for SLE12* and SLE15*? :)
Comment 2 Michael Matz 2022-08-26 13:17:54 UTC
Yup.  Will be prepared over the next weeks.
Comment 7 Swamp Workflow Management 2022-11-21 14:30:12 UTC
SUSE-SU-2022:4146-1: An update that solves 10 vulnerabilities, contains 10 features and has three fixes is now available.

Category: security (moderate)
Bug References: 1142579,1185597,1185712,1188374,1191473,1193929,1194783,1197592,1198237,1202816,1202966,1202967,1202969
CVE References: CVE-2019-1010204,CVE-2021-3530,CVE-2021-3648,CVE-2021-3826,CVE-2021-45078,CVE-2021-46195,CVE-2022-27943,CVE-2022-38126,CVE-2022-38127,CVE-2022-38533
JIRA References: PED-2029,PED-2030,PED-2031,PED-2032,PED-2033,PED-2034,PED-2035,PED-2038,SLE-25046,SLE-25047
Sources used:
openSUSE Leap 15.4 (src):    binutils-2.39-150100.7.40.1, cross-aarch64-binutils-2.39-150100.7.40.1, cross-arm-binutils-2.39-150100.7.40.1, cross-avr-binutils-2.39-150100.7.40.1, cross-epiphany-binutils-2.39-150100.7.40.1, cross-hppa-binutils-2.39-150100.7.40.1, cross-hppa64-binutils-2.39-150100.7.40.1, cross-i386-binutils-2.39-150100.7.40.1, cross-ia64-binutils-2.39-150100.7.40.1, cross-m68k-binutils-2.39-150100.7.40.1, cross-mips-binutils-2.39-150100.7.40.1, cross-ppc-binutils-2.39-150100.7.40.1, cross-ppc64-binutils-2.39-150100.7.40.1, cross-ppc64le-binutils-2.39-150100.7.40.1, cross-riscv64-binutils-2.39-150100.7.40.1, cross-rx-binutils-2.39-150100.7.40.1, cross-s390-binutils-2.39-150100.7.40.1, cross-s390x-binutils-2.39-150100.7.40.1, cross-sparc-binutils-2.39-150100.7.40.1, cross-sparc64-binutils-2.39-150100.7.40.1, cross-spu-binutils-2.39-150100.7.40.1, cross-x86_64-binutils-2.39-150100.7.40.1
openSUSE Leap 15.3 (src):    binutils-2.39-150100.7.40.1, cross-aarch64-binutils-2.39-150100.7.40.1, cross-arm-binutils-2.39-150100.7.40.1, cross-avr-binutils-2.39-150100.7.40.1, cross-epiphany-binutils-2.39-150100.7.40.1, cross-hppa-binutils-2.39-150100.7.40.1, cross-hppa64-binutils-2.39-150100.7.40.1, cross-i386-binutils-2.39-150100.7.40.1, cross-ia64-binutils-2.39-150100.7.40.1, cross-m68k-binutils-2.39-150100.7.40.1, cross-mips-binutils-2.39-150100.7.40.1, cross-ppc-binutils-2.39-150100.7.40.1, cross-ppc64-binutils-2.39-150100.7.40.1, cross-ppc64le-binutils-2.39-150100.7.40.1, cross-riscv64-binutils-2.39-150100.7.40.1, cross-rx-binutils-2.39-150100.7.40.1, cross-s390-binutils-2.39-150100.7.40.1, cross-s390x-binutils-2.39-150100.7.40.1, cross-sparc-binutils-2.39-150100.7.40.1, cross-sparc64-binutils-2.39-150100.7.40.1, cross-spu-binutils-2.39-150100.7.40.1, cross-x86_64-binutils-2.39-150100.7.40.1
SUSE Manager Server 4.1 (src):    binutils-2.39-150100.7.40.1
SUSE Manager Retail Branch Server 4.1 (src):    binutils-2.39-150100.7.40.1
SUSE Manager Proxy 4.1 (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP4 (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Module for Development Tools 15-SP4 (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Module for Development Tools 15-SP3 (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Module for Basesystem 15-SP4 (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise Module for Basesystem 15-SP3 (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    binutils-2.39-150100.7.40.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    binutils-2.39-150100.7.40.1
SUSE Enterprise Storage 7 (src):    binutils-2.39-150100.7.40.1
SUSE Enterprise Storage 6 (src):    binutils-2.39-150100.7.40.1
SUSE CaaS Platform 4.0 (src):    binutils-2.39-150100.7.40.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 8 Swamp Workflow Management 2022-11-29 17:45:43 UTC
SUSE-SU-2022:4277-1: An update that solves 10 vulnerabilities, contains 10 features and has 5 fixes is now available.

Category: security (important)
Bug References: 1142579,1185597,1185712,1188374,1191473,1191908,1193929,1194783,1197592,1198237,1198458,1202816,1202966,1202967,1202969
CVE References: CVE-2019-1010204,CVE-2021-3530,CVE-2021-3648,CVE-2021-3826,CVE-2021-45078,CVE-2021-46195,CVE-2022-27943,CVE-2022-38126,CVE-2022-38127,CVE-2022-38533
JIRA References: PED-2029,PED-2030,PED-2031,PED-2032,PED-2033,PED-2034,PED-2035,PED-2038,SLE-25046,SLE-25047
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    binutils-2.39-9.50.1
SUSE OpenStack Cloud 9 (src):    binutils-2.39-9.50.1
SUSE Linux Enterprise Software Development Kit 12-SP5 (src):    binutils-2.39-9.50.1, cross-ppc-binutils-2.39-9.50.1, cross-spu-binutils-2.39-9.50.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    binutils-2.39-9.50.1
SUSE Linux Enterprise Server 12-SP5 (src):    binutils-2.39-9.50.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    binutils-2.39-9.50.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    binutils-2.39-9.50.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    binutils-2.39-9.50.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.