Bug 1203677 - (CVE-2022-41317) VUL-0: CVE-2022-41317: squid: SQUID-2022:1 Exposure of Sensitive Information in Cache Manager
(CVE-2022-41317)
VUL-0: CVE-2022-41317: squid: SQUID-2022:1 Exposure of Sensitive Information ...
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Normal
: ---
Assigned To: Security Team bot
Security Team bot
https://smash.suse.de/issue/343349/
CVSSv3.1:SUSE:CVE-2022-41317:6.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-09-23 07:45 UTC by Marcus Meissner
Modified: 2022-10-17 16:28 UTC (History)
1 user (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Meissner 2022-09-23 07:45:33 UTC
CVE-2022-41317

https://github.com/squid-cache/squid/security/advisories//GHSA-rcg9-7fqm-83mq

Package
squid (Squid)
Affected versions 4.9-4.17, 5.0.6-5.6
Patched versions 5.7
Description

Problem Description:

Due to inconsistent handling of internal URIs Squid is
vulnerable to Exposure of Sensitive Information about clients
using the proxy.

Severity:

This problem allows a trusted client to directly access cache
manager information bypassing the manager ACL protection.

The available cache manager information contains records of
internal network structure, client credentials, client identity
and client traffic behaviour.

CVSS Score of 6.4
https://nvd.nist.gov/vuln-metrics/cvss/v3-calculator?vector=AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N/E:F/RL:X/RC:C/CR:M/IR:X/AR:X/MAV:X/MAC:L/MPR:L/MUI:X/MS:X/MC:H/MI:X/MA:X&version=3.1

Updated Packages:

This bug is fixed by Squid version 5.7.

In addition, patches addressing this problem for the stable
releases can be found in our patch archives:

Squid 4:
http://www.squid-cache.org/Versions/v4/changesets/SQUID-2022_1.patch

Squid 5:
http://www.squid-cache.org/Versions/v5/changesets/SQUID-2022_1.patch

If you are using a prepackaged version of Squid then please refer
to the package vendor for availability information on updated
packages.

Determining if your version is vulnerable:

Squid older than 4.9 are not vulnerable.

All Squid-4.9 up to and including 4.14 have not been tested, but
should be assumed to be vulnerable.

All Squid-4.15 up to and including 4.17 are vulnerable.

All Squid-5.0.6 up to and including 5.6 are vulnerable.

Workaround:

Add the following to squid.conf:

acl manager url_regex +i ^[^:]+://[^/]+/squid-internal-mgr/

Contact details for the Squid project:

For installation / upgrade support on binary packaged versions
of Squid: Your first point of contact should be your binary
package vendor.

If you install and build Squid from the original Squid sources
then the squid-users@lists.squid-cache.org mailing list is your
primary support point. For subscription details see
http://www.squid-cache.org/Support/mailing-lists.html.

For reporting of non-security bugs in the latest STABLE release
the squid bugzilla database should be used
http://bugs.squid-cache.org/.

For reporting of security sensitive bugs send an email to the
squid-bugs@lists.squid-cache.org mailing list. It's a closed
list (though anyone can post) and security related bug reports
are treated in confidence until the impact has been established.

Credits:

This vulnerability was discovered by Mikhail Evdokimov
(aka konata).

Initial fix by Amos Jeffries of Treehouse Networks Ltd.

Revision history:

2022-04-17 18:30:52 UTC Initial Report
2022-08-08 11:01:47 UTC Initial Fix released
2022-09-23 05:00:00 UTC Advisory Released
Comment 1 Marcus Meissner 2022-09-23 08:06:36 UTC
squid 3.5 also seems affected, so all squid in SLE12 and SLE15 are affected.

squid3 3.1 and squid 2.7 on SLE11 seem not affected.
Comment 3 OBSbugzilla Bot 2022-09-26 11:05:02 UTC
This is an autogenerated message for OBS integration:
This bug (1203677) was mentioned in
https://build.opensuse.org/request/show/1006088 Factory / squid
Comment 5 Swamp Workflow Management 2022-10-06 13:26:12 UTC
SUSE-SU-2022:3533-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1203677,1203680
CVE References: CVE-2022-41317,CVE-2022-41318
JIRA References: 
Sources used:
SUSE OpenStack Cloud Crowbar 9 (src):    squid-3.5.21-26.38.1
SUSE OpenStack Cloud 9 (src):    squid-3.5.21-26.38.1
SUSE Linux Enterprise Server for SAP 12-SP4 (src):    squid-3.5.21-26.38.1
SUSE Linux Enterprise Server 12-SP4-LTSS (src):    squid-3.5.21-26.38.1
SUSE Linux Enterprise Server 12-SP3-BCL (src):    squid-3.5.21-26.38.1
SUSE Linux Enterprise Server 12-SP2-BCL (src):    squid-3.5.21-26.38.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 6 Swamp Workflow Management 2022-10-06 13:32:26 UTC
SUSE-SU-2022:3532-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1203677,1203680
CVE References: CVE-2022-41317,CVE-2022-41318
JIRA References: 
Sources used:
SUSE Linux Enterprise Server 12-SP5 (src):    squid-4.17-4.27.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 7 Swamp Workflow Management 2022-10-06 13:33:20 UTC
SUSE-SU-2022:3531-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1203677,1203680
CVE References: CVE-2022-41317,CVE-2022-41318
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    squid-5.7-150400.3.6.1
SUSE Linux Enterprise Module for Server Applications 15-SP4 (src):    squid-5.7-150400.3.6.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2022-10-17 16:28:18 UTC
SUSE-SU-2022:3596-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1203677,1203680
CVE References: CVE-2022-41317,CVE-2022-41318
JIRA References: 
Sources used:
openSUSE Leap 15.3 (src):    squid-4.17-150000.5.35.1
SUSE Manager Server 4.1 (src):    squid-4.17-150000.5.35.1
SUSE Manager Retail Branch Server 4.1 (src):    squid-4.17-150000.5.35.1
SUSE Manager Proxy 4.1 (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise Server for SAP 15-SP1 (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise Server for SAP 15 (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise Server 15-SP2-BCL (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise Server 15-SP1-LTSS (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise Server 15-SP1-BCL (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise Server 15-LTSS (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise Module for Server Applications 15-SP3 (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise High Performance Computing 15-SP2-ESPOS (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise High Performance Computing 15-LTSS (src):    squid-4.17-150000.5.35.1
SUSE Linux Enterprise High Performance Computing 15-ESPOS (src):    squid-4.17-150000.5.35.1
SUSE Enterprise Storage 7 (src):    squid-4.17-150000.5.35.1
SUSE Enterprise Storage 6 (src):    squid-4.17-150000.5.35.1
SUSE CaaS Platform 4.0 (src):    squid-4.17-150000.5.35.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.