Bug 1204526 - (CVE-2022-41741) VUL-0: CVE-2022-41741: nginx: out-of-bounds write in ngx_http_mp4_module
(CVE-2022-41741)
VUL-0: CVE-2022-41741: nginx: out-of-bounds write in ngx_http_mp4_module
Status: NEW
Classification: Novell Products
Product: SUSE Security Incidents
Classification: Novell Products
Component: Incidents
unspecified
Other Other
: P3 - Medium : Major
: ---
Assigned To: Felix Schnizlein
Security Team bot
https://smash.suse.de/issue/345912/
CVSSv3.1:SUSE:CVE-2022-41741:7.5:(AV:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2022-10-20 08:33 UTC by Thomas Leroy
Modified: 2023-01-30 20:23 UTC (History)
5 users (show)

See Also:
Found By: Security Response Team
Services Priority:
Business Priority:
Blocker: ---
Marketing QA Status: ---
IT Deployment: ---
stoyan.manolov: needinfo? (fschnizlein)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Leroy 2022-10-20 08:33:08 UTC
CVE-2022-41741

NGINX Open Source before versions 1.23.2 and 1.22.1, NGINX Open Source Subscription before versions R2 P1 and R1 P1, and NGINX Plus before versions R27 P1 and R26 P1 have a vulnerability in the module ngx_http_mp4_module that might allow a local attacker to corrupt NGINX worker memory, resulting in its termination or potential other impact using a specially crafted audio or video file. The issue affects only NGINX products that are built with the ngx_http_mp4_module, when the mp4 directive is used in the configuration file. Further, the attack is possible only if an attacker can trigger processing of a specially crafted audio or video file with the module ngx_http_mp4_module.

Upstream commit:
https://github.com/nginx/nginx/commit/0d23105373e6d8a720b9826079c077b9b4be919d

References:
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2022-41741
https://www.cve.org/CVERecord?id=CVE-2022-41741
http://www.cvedetails.com/cve/CVE-2022-41741/
https://support.f5.com/csp/article/K81926432
Comment 1 Thomas Leroy 2022-10-20 08:39:18 UTC
All maintained codestreams affected:
- SUSE:SLE-15:Update
- SUSE:SLE-15-SP1:Update
- SUSE:SLE-15-SP2:Update
- SUSE:SLE-15-SP3:Update
- SUSE:SLE-15-SP4:Update
- openSUSE:Factory
Comment 8 Swamp Workflow Management 2023-01-27 20:22:32 UTC
SUSE-SU-2023:0205-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1204526,1204527
CVE References: CVE-2022-41741,CVE-2022-41742
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    nginx-1.19.8-150300.3.12.1
SUSE Manager Server 4.2 (src):    nginx-1.19.8-150300.3.12.1
SUSE Manager Retail Branch Server 4.2 (src):    nginx-1.19.8-150300.3.12.1
SUSE Manager Proxy 4.2 (src):    nginx-1.19.8-150300.3.12.1
SUSE Linux Enterprise Server for SAP 15-SP3 (src):    nginx-1.19.8-150300.3.12.1
SUSE Linux Enterprise Server 15-SP3-LTSS (src):    nginx-1.19.8-150300.3.12.1
SUSE Linux Enterprise Realtime Extension 15-SP3 (src):    nginx-1.19.8-150300.3.12.1
SUSE Linux Enterprise High Performance Computing 15-SP3-LTSS (src):    nginx-1.19.8-150300.3.12.1
SUSE Linux Enterprise High Performance Computing 15-SP3-ESPOS (src):    nginx-1.19.8-150300.3.12.1
SUSE Enterprise Storage 7.1 (src):    nginx-1.19.8-150300.3.12.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 9 Swamp Workflow Management 2023-01-30 20:19:19 UTC
SUSE-SU-2023:0210-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1204526,1204527
CVE References: CVE-2022-41741,CVE-2022-41742
JIRA References: 
Sources used:
SUSE Linux Enterprise Server for SAP 15-SP2 (src):    nginx-1.16.1-150200.3.12.1
SUSE Linux Enterprise Server 15-SP2-LTSS (src):    nginx-1.16.1-150200.3.12.1
SUSE Linux Enterprise High Performance Computing 15-SP2-LTSS (src):    nginx-1.16.1-150200.3.12.1
SUSE Enterprise Storage 7 (src):    nginx-1.16.1-150200.3.12.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.
Comment 10 Swamp Workflow Management 2023-01-30 20:23:18 UTC
SUSE-SU-2023:0212-1: An update that fixes two vulnerabilities is now available.

Category: security (important)
Bug References: 1204526,1204527
CVE References: CVE-2022-41741,CVE-2022-41742
JIRA References: 
Sources used:
openSUSE Leap 15.4 (src):    nginx-1.21.5-150400.3.3.1
SUSE Linux Enterprise Module for Server Applications 15-SP4 (src):    nginx-1.21.5-150400.3.3.1

NOTE: This line indicates an update has been released for the listed product(s). At times this might be only a partial fix. If you have questions please reach out to maintenance coordination.